PLEX, Dolby Digital & Content Error Messages

I have successfully jailbreak the black appletv and istall plex!!!

but the following errors occur:

1. no ac3 or dts passthrough

how can I fix it???  the only thing that is always running on my reciever is dolby prologic!!!

2. the plex server is running and full recognized, but there comes a error message when I play a movie or tv show like "An error occurred loading this content - Try again later"

The hard drives are connected to my TimeCapsule.

I somehow got the feeling that the appletv is not able to wake up the hdd (if it is not being used). and so this error message appears.

because when I had the hdd used manually (and wake it up) and try to connect over plex again then the movies played normally.

hope someone can help me...

I have the same Dolby passthrough problem; there is none. Everything downconverts to stereo.

Also, how do I upgrade from Plex client 0.6.3 to the latest version 0.6.4? I tried uninstalling then re-installing. Still 0.6.3.

I hope it comes soon an update which allows the pass-through!!! :/

and what about the second problem?

I have just now tried again ... and the content could not be played. this morning when I was manually on the hard drive, it worked over PLEX in ATV2!

I can only get movies to play in dolby II. When I play them through Itunes they are dolby digital.  This has to be a PLEX issue.  Anybody have a workaround?

AC3 passthrough is broken for me too. Any of the devs aware of this?