Plex cast list issues (random order & empty search results)

7.5.1 version for AppleTV STILL DOES NOT give a complete list of films in the database when searching by cast. I do not want to even try “Refresh Metadata,” which will take a couple of days, only to find it doesn’t work. “Scan for Changes” does NOT restore the search by cast which worked fine until the update. I would rather have the search feature work, than have access to trailers.

Mine seems to be ok now. Though I had to wait for full fetching of metadata to finished. You may have to rebuild your metadata by deleting and refreshing. If you have a big library, this will take a while.


Well, the cast database is metadata. Scan for changes simply looks for new files in the watched folders (or identifies files that are no longer present); it doesn’t do anything to update metadata.

You can’t insist 7.5.1 fixes nothing when you aren’t willing to let 7.5.1 refresh the metadata database. :man_shrugging:t2:

Refresh, restart - and again the same procedure: This Update does not fix anything in regards to Search and cast/director list.

I search for example for Brad Pitt and up pops 7 folders, 3 with his picture, 4 without. In each folder there are different movies with/by him.

It is a mess.

Kind regards.

Jens, Copenhagen

OK, so Infuse 7.5.1 will search by cast for me now, but I had to do Settings → Library → Refresh Metadata to get it to work. Scan for Changes accomplishes nothing. It processes about 200 movies per minute (45 minutes total) for a large library.

  1. I will now have to do this on EACH of my 4 AppleTVs, as well as my desktop and laptop computers. VERY TIME CONSUMING.

  2. I don’t want to have to do this henceforth for each new version.

  3. If Firecore would just reveal where the datafiles are stored on my hard drive, I could save time just copying the library data from one computer to the other.

  4. Hopefully any new titles I add to the library will incorporate properly into the database, without having to renew metadata each time. (Hopefully “Scan for Changes” will accomplish this.

You can search the forums to find out where the data is stored, but you risk corrupting the data so I would avoid it.

That’s not what “Scan for Changes” is for. So, no.

While this was an unexpected bug that was not discovered until after the release of 7.5, we don’t expect this to happen again in the future.

A unique Plex login token is used for each device, so it’s not recommended to copy data manually from one device to another.

1 Like

After making sure all devices (ATV, Mac, iPad) have updated to 7.5.1, did a metadata refresh and now it’s all working as it should regarding the cast list order and cast search. :+1:

Thanks for quickly taking care of this, Firecore!

1 Like

So you have all, really all folders filled out with pictures in the Cast and Crew? Not talking about order, which is now fixed with 7.5.1.

The Ten Commandments (1956) for example omits the picture of Cecil B. DeMille, the director. And I could bore you to Death with thousands of others.

Kind regards.

Jens, Copenhagen

If refreshing the metadata does not help, you may try removing the Plex share and re-adding it.

This generally isn’t needed, but would be a way to start fresh.

@james Appreciate you all for getting the fix out! 7.5.1 seems to have fixed the issue on my end as well as the bug with hide spoilers not working properly. Thanks so much for always listening to your users and staying on top of things! It definitely doesn’t go unnoticed :smile:


In my case, 7.5.1 solved the issue.

1 Like

The issue is still there on Apple TV and iPhone for me with 7.5.1.
Done both full metadata refresh and then even deleting and re-adding the PMS libraries …

1 Like

Which issue are you seeing?

Which version of PMS?

Can you send in a report from your device, and post the 5 digit code here?

Yes, it is still not fixed.

Is there a time horizon for this?

Kind regards.

Jens, Copenhagen

1 Like

I’m having this issue too, still with 7.5.1 … Only a few movies visible when searching for an actor :confused: … all devices (iPad, iPhone, AppleTV4k)

edit: I’ll now try refresh meta data - lets see how long this will take :smiley:

edit2: after refresh of meta data it worked now :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.