please help, unable to get ATV2 into DFU mode jailbreaking with SeasOnpass

Picked up an ATV2 today and first think I did was update to 4.3 (should have stayed with the old firmware...) and have been attempting to jailbreak it every since. Downloaded the latest version of SeasOnpass, load it up, it gets to the plug your ATV in and hold menu and play for seven seconds, which I do and nothing happens. From what I understand, Seasonpass is supposed to automatically recognize that it's in DFU mode and launch itunes. This doesn't happen, Seasonpass just stays at the connect ATV screen.

I'm goings nuts here, please help

Quick iphone video to show what I'm (not?) doing http://www.youtube.com/watch?v=FXR4GfJc9V0

Try holding the remote buttons (menu+play) as you're plugging it in. I believe that you can let go when the light rapidly blinks.

 

Also, try holding menu+down while it's plugged in for a bunch of seconds, then let go and start holding menu+play. When you see the light start blinking rapidly (very quickly, but slow enough to not be solid), let go.

 

 

i was never able to get into DFU mode as desscribed on my ATV2 without having the power cable pluged in. Not sure why, but that is the way it was and I was indeed able to jailbreak the unit. I did this three times tethered adn once untethered, each time I had to have th epower cable plugged in.

 

Hope this helps.

 

Henry

Having the power cable plugged in worked for me also.

The problem I had was with itunes. everytime I attempted to go into DFU mode my itunes detected my atv.  By disabling the itunes helper in windows that solved the problem.  I don’t know if it’s something similar with OS X

Same for me, nothing would work, until I plugged in Power as well, and then it would go into DFU mode. It resolved the issue! Thanks!!

une the power cable first connect the usb for 7 second then connect the power cord count 3 second and press and hold the 2  button (play and menu) and when the light start blinking fast release the 2 button and open ITUNES and you will see your atv , you can also use IRB4 after you enter in DFU it is helping getting rid of error 1601 ,I have tried many way to get into DFU and this one work for sure GOOD LUKE

This worked!

I need a source for the mini usb cable.