Please help! SMB and AFP shares do not work :(

I’m getting really frustrated with aTV Flash. All I want to be able to do is access the folder of DVD rips on my NAS. I don’t care about any other aTV Flash features. I just want this ONE THING to work - and no matter what I do, it fails.

I really hope someone here can help.

I’ve tried access my share (which I have no trouble accessing from my Mac) via AFP. That produced a bunch of errors. The aTV Flash folks told me to try SMB without offering any insight into what the AFP errors meant. So, now I’ve tried SMB. And this is what I get:

Network Mount Failed!
mount_smbfs: UNC no resp dict, rd=0x0
mount_smbfs: UNC selection out of bounds 8 > 8

When I try AFP, this is what I get:

Network Mount Failed!
mount_afp: the mount flags are 0000 the altflags are 0020
mount_afp: AFPMountURL returned error 22, errno is 2


Obviously, other people are able to get this to work. What am I doing wrong???

Any help would be much appreciated. At this point, I’m ready to just throw the whole Apple TV in the trash.


Hi - I had the same problems and frustrations you had. What worked for me was to manually mount my drive using ssh using the terminal:

ssh frontrow@appletv.local
mkdir /Volumes/Drivename
mount -t smbfs //user:pass@ /Volumes/Drivename/

Now, using the “Files” menu on the Apple TV root menu, I can see the volume I just mounted, and am now streaming videos off of it.