Please help me jailbreak .. Apple TV 2 (black)

Hi All,

I tried to jailbreak my apple tv yesterday but no matter what I tried I couldn’t make the apple tv light come on when it was connected to the PC via the usb cable it would only come on when the power lead was plugged in. The instructions say it shouldn’t be in…

anyway I tried to jailbreak with the power lead in but when I was asked to press menu and play for 7 seconds it just came up with an error saying your device isn’t supported by seas0npass. Im sure its an apple tv gen 2 as its pretty much a year old. I also think its running the latest software as it updated the other day.

I’m very new to all this jailbreaking etc so please if you can help me I’d really appreciate it.



Just because it is a year old does not mean it is an ATV2  as the ATV3 has been on sale for nearly 18 months now.   The easiest way to tell is whether it supports 1080p output - if it does it is an ATV3.

Oh right… how do I tell then?

On the ATV go to Settings->Genereal->About and see what TV resolution is being used.    You can also get the detailed model number from there.


no need to check if the light doens’t come on when it’s only the usb connected after you plug the plug in an unplugged it you have a gen 3


or if you perfer to see for yourself, turn it over the first line near the bottom on your unit you will c model: a1427 or 69


you are correct its gen3 but the good news is my other is gen2 i’m just trying to jailbreak it now… once done I need help to do xbmc? I would like to watch films that are saved to my NAS… will xbmc do this?



ok the firecore jailbreak process seems to complete however when I plug the atv back into my TV i see the apple logo but then it goes blank and nothing happens and the light on the atv just blinks? have I screwd up??

What version of firmware? If it is the latest 5.3 then the jailbreak is tethered. This means the ATV will not boot (start up) successfully without you comnecting the ATV via USB to your PC/Mac and going through the tethered boot process (the jailbreak and restore steps are not needed again). It sounds as if your ATV might be waiting for the tethered boot? The tethered boot will be required any time power has been removed (or you do a hard reset).

How can I see what version of firmware its has? tethered is no good to me as my PC isnt in the same room as my ATV

I’m guessing if it is 5.3 I can restore it back via itunes so I can still use it it just wont be jailbroken.