playing movies off of my 2tb time capsule on apple tv 2 ?

is there a way to stream movies i have on my apple time capsule to the apple tv 2 ?

Yep - details for setting up Media Player to connect to your Time Capsule can be found here.

thank you :slight_smile:

I have followed the solution described in this post but I get an error message saying something like “AFP connection failed … etc”, I am NOT able to connect to my TC. I am using all the latest versions of all software in use, i.e TC is updated, Macbook Air is updated, Apple Tv is updated and has been jailbroken with the latest version of seasonpass, and I am running the latest version of atv flash.

Do you have the correct name & password? It took me like 15-20 min to figure out what my password was :slight_smile:

Also, please keep in mind that when connecting to a Time Capsule or Airport Extreme a username of ‘guest’ should be used.

Actually I have to disagree. I even don’t have the Guest activated. I just used my name and password, which I use to access the Time Capsule and it works just great! :slight_smile:

That works too. :) 

i have tried using guest as user and entering the password, i have also tried leaving the password field blank. When you are saying that you used your name, do you mean the exact name as on the user on your mac or what?

Yes, exactly that name and password.

I’m sorry but now I’m confused, should I use the username and password for my mac? I don’t understand the logic in that when all I want to use is the apple tv and the TC …

Besides, that wouldn’t work for me since my username contains the letter “ø” which is impossible to write on the apple tv.

I used the same name as for my Mac Account. I don’t exactly remember how did I set up my Time Capsule, but the name and password for Time Capsule are identical with Mac account, which must have been done somehow automatically. Just try that and you’ll see if that works or not…

 

Edit: with the special character - few years ago I’ve changed my account name so it doesn’t contain any special character to avoid this kind of problems (my name contain “š”)…

I have now tried to enter both “guest” and my own username and tried with different passwords, both blanks and those that I’ve set myself but I still get the same AFP connection error. I have also sent in a support ticket but still no success, does anyone else know a potential other solution?

Update: I have now solved the problem but I have no idea how I did it. It suddenly worked after I fiddled with the manual settings in the airport-settings. 

I’m glad it works:) enjoy it;)

Ok, so I’m bumping this again as my tc suddenly stopped connecting with my tav. I’ve tried everything again but no success, it won’t accept any of my usernames or passwords. Does anyone have this set-up functioning with all the latest software? I am running 4.4.4 with 1.4-4 of maintenance.

edit: Goddamned it, I’ve been fiddling around trying the same things for hour after hour and 5 minutes after I posted this everything suddenly works again even though I did nothing different from before. In the end, what solved it was deleting the share, restarting the time capsule and adding the share again. Even though I tried this several times it only worked after I posted here on the forum. Do you guys have some sort of an automatic fixit-robot that crawls these forums or what? :wink:

I cannot figure out my username to save my life. I can’t even remember setting up one. I know the password to my time capsule, is there anyway I can possibly figure out a username? I’ve tried emails, nicknames, my name, etc etc. I tried logging in with guest tried leaving everything blank and I cannot figure it out.  ANY pointers, tips, etc is MUCH appreciated.

Hi all,

I thought I might put in my 2 cent as I've spent the last few days trying to figure this out...

 

My network consists of a shared external HDD attached to a Time Capsule as the main router. I then have both PC and Mac connected to this drive as well as an Apple TV 2.

 

The Apple TV 2 is running FireCore (aTV Flash (black) 2.0.2) and reading media from the shared network HDD. It took me quite a while to figure all this out as the documentation is a bit limited as to exactly how (“..enter your device's details manually”, Media 101 - Basic Setup http://support.firecore.com/entries/20322512-media-101-basic-setup).

 

I have posted previously asking for help as well…(http://forum.firecore.com/topic/9170) without any response as yet…. I pretty much ended up solving the issue through trial and error assisted by numerous posts through different forums.

 

Here’s my take on the set up configuration that worked for me…(please note these names are used to show how CAPITALS and spaces are being translated to the address)

 

Time Capsule

 

Name:  Time Capsule

External HDD: ELEMENTS (the folder I have my movie is in, is named Media)

Password: password (not the actual password in my configuration)

 

Open Airport Utility and highlight, under the Drive tab the external HDD and tick the box for shared drive.

 

 

Apple TV

 

Connect to the shared network through the native Apple TV OS, under General > Network….make sure you are connected to the nominated Network (“Time Capsule” in my case)

 

Open up the Maintenance tab and enable / install media player of your choice (I have both Media and XBMC enabled)

 

Here’s where it may get a bit tricky, the two applications(Media and XBMC) use two different addresses to connect to the shared HDD.

 

 

Media

 

I have found the Media one a bit odd and only connect to my library in a certain way, when I try to access the media files (avi format) through the “My Files / Library” I get a "Playback error, an error occurred loading this content" however when I access the files through “My Files / Remote / ELEMENTS it works fine……see my post here http://forum.firecore.com/topic/9172.

 

Go to “Add Share”, click Other and allow for SMB connection.

 

Name:  as the name implies, it's the name you've given your Time Capsule (Time Capsule in my case)

Server: Time-Capsule.local/ELEMENTS/Media    (note the space is required to be a dash and the capitals used)

User name: <left blank>

Password = password     (not the actual password in my configuration)

Workgroup: <left blank>

 

Press test connection – if pass, then proceed with setting up a library as per http://support.firecore.com/entries/20322512-media-101-basic-setup

 

 

XBMC

 

This one is slightly different as it will require the password for the connection in the actual smb address.

 

Access Videos > Files

 

Now to type the path to the shared external network HDD.

 

   smb://Time-Capsule.local:password@10.0.1.2/ELEMENTS/Media

 

press Done and OK to save. It will now progress with scanning and loading the media library files.

 

I did have some problem with the scanning (or scraping) for new and updated files with the default “scraper”, problem was resolved by selecting a different one (in my case I selected the IMDb)

 

 

I know all these setting may not work for everyone but it may help someone along the way like other posts did to me.

 

Also refer to this post as it help me along the way http://forum.firecore.com/topic/4486#comment-22716

 

….and this one for setting up the media http://www.avforums.com/forums/home-entertainment-pcs/1556617-xbmc-setup-support-thread-updated-version-11-eden.html

 

 /Fred

 

Just updated to ios 5 on my atv2. I had the hardest time trying to get my TC setup. Now that I figured it with all the forum post, now I can’t play one single thing off my TC. I was able to steam fine before the update. Now all I get is playback error, no matter what video I select. Can anyone please help me? I have submitted a diagnostic info already.

TC setup SMB

ATVFlash Black 2.0.2

 

I have had a similar problem playing files a certain way. Lodged a diagnostic report a long time ago but still no solution. I now only use XBMC to play my files.

/Fred