Playback stutters after moving playhead on Apple TV, iPad and iPhone

Some files play fine in Infuse on Mac, or even in the Files app on iPad, but not in Infuse on Apple TV or iPad: when you go skip to a different time, only a frame every second or so plays (probably the keyframes) and Infuse never recovers to play the video normally.

This is with the latest versions of iPadOS and tvOS.

This even happens when playing the file from a USB-C SSD to the internal memory on my iPad Pro.
The same file plays perfectly with the Files app on the iPad, from USB SSD or the internal memory (it should not be in the Infuse folder, otherwise Infuse will be used to play it).

The files have been created with Apple Compressor 4.6.6 (latest), then remuxed with ff-Works(ffmpeg).
This example is a pretty standard 4K 23.976fps HDR 10 video with ALAC audio in a .mov container.
I tried muxing to .mkv with MkvToolnix or changing the audio format with no success. With the files on my NAS and on a OneDrive with the same results. And with the files stored locally on my iPad Pro too.

I just sent a big file to the Dropbox (28.4GB). Its name starts with “From Jerome” .
Just play the movie in Infuse, go to 1h45mn0S (I just tried it), go back 10s by pressing the button in the UI or on the remote and voilà.

Thanks in advance,
Jérôme.

1 Like

I made a few more tests.

  • the problematic video plays perfectly with Apple players on my Apple devices: QuickTime Player on Macs, including a Mac mini 2012 with Sonoma via OCLP, via the files app on my iPad Pro 2020 to old iPhone XS Max, and via the “Computers” app on my Apple TV via homesharing.
    It has issues in Infuse on iPhone, iPad, Apple TV but works perfectly with Infuse on the Mac.

  • I changed the setting in Compressor to a fixed 23.976(actually 24000/1001)fps instead of automatic frame rate. The resulting file stutters for about a second but then plays perfectly in Infuse.

  • I changed the original setting by unchecking “allow frame reordering” in Compressor - the resulting file plays perfectly in Infuse, with no stuttering.
    The Compressor user guide says « Important: If you select “Allow frame reordering,” your output file may be more efficiently compressed but may not be compatible with decoders on older hardware. »

So my guess is on an outdated component that does not handle frame reordering very well.

@James I just uploaded to the Dropbox a zip file with 3 four minutes extracts that have the described behavior. The tip file is named “PlaybackIssueForInfuse.zip”

Any news about this @james ?

I am a bit disturbed that Infuse on Apple TV cannot play reliably pretty standard HEVC videos, that pose no problem to the built-in player. I used to trust Infuse to play everything I threw at it.
Now it has issues with files I encoded with standard settings in Apple Compressor.

It seems to be the same issue as the one reported here https://community.firecore.com/t/delay-after-skipping-10-seconds/

It is very disappointing to have zero news about this.
I have to reencode movies or go for a different player.
I never know if a previously encoded movie will work with Infuse on my Apple TV 4K.
@james ?

1 Like

I am not sure if this is going to help everyone, but I think I have stumbled onto a workaround that is easy enough.

The workaround is running the file through MKVToolNix (GUI), with no changes or alterations, seems to fix the problem.

It’d be interesting to see if you have another video that is exhibiting these problems to run it through mediainfo then through MKVtoolNix and then mediainfo after and see if the before and after reports have any differences.

1 Like

NIce thanks.
However, I quite liked the time when Infuse could play anything you threw at it, without having to remux or reencode it.

I did, but it only looked like the writing lib had changed.

I will do a test tonight and post the results in case someone with more knowledge can tell the difference.

1 Like

It certainly would be interesting!
Did that in November, 3 months agp, wrote the results in the first post, and sent the videos to Firecore via Dropbox.
What would be very interesting is someone from the Infuse team actually look at the issue.

It looks like there are some differences with metadata, but it only looks like the writing application/library is the only significant item.

If you see anything interesting, please share. This is an easy workaround but I would like to know what is really going on.

1 Like

Thank you for that! I was interpreting it that you weren’t doing any changes, just opening it with MKVToolnix but it appears that it’s just opening and then saving correct? I’m hoping that something will stick out to someone more familiar with the writing libraries and apps where the differences seem to be. I’m very much a novice so I defer to the pros who use this stuff every day.

Again thanks for doing this. :+1:

That’s correct. Ad the file. Click “Start Multiplexing”.

I wonder if you just open up the header editor in Mkvtoolnix and make a minor change and save if that would also fix it.

1 Like

That didn’t fix it.

Opened the problem file in Header Edit and changed the video language to English (it was Undetermined).

Before and after Header Edit. No other changes.
HeaderEdit

2 Likes

Can confirm the only fix for 4K 10bit HEVC playback with smooth seeking is to run the file through MKVToolnix without changes. Night and day difference.

I’ve found VideoToolbox encodes have no stutter without the MKVToolnix step, but I’ve been getting inconsistent bitrates even when using Avg Bitrate in Handbrake.

Both versions require enough keyframes and frames to seek smoothly without stuttering.

keyint=24:bframes=3 is what’s working for me

Infuse used to work without any of these extra steps. Wonder what changed. Plex app works fine.

edit : Spoke too soon. Only works with current generation ATV 4K. Last generation ATV 4K still experiencing stuttering when seeking. This is maddening. If this doesn’t get fixed soon I’m canceling my sub and moving back to Plex. Is anyone from Firecore going to respond or update?

Playback improvements are on the roadmap and this thread is tagged as researching so I’m guessing it will be looked into at that point. Infuse was not messing with the playback core during 7.7 testing.

I to have noticed Infuse sometimes has playback issues after seeking a significant amount, or even when doing rapid seeks. Either the picture is frozen, while audio plays, or there is significant pixelization/garbled image for a few secs.

This is with most any files, h264, or h265. But, is mostly prevalent with 4K HEVC files. The larger the file, bigger bitrate etc, the more likely it is to do this.
Though, i have had it do it on 1080p h264 files, and have to back out to menu, and re-start playing to unfrezze the image.

This has been happing even before the most recent update. Overall, minor issue for me, as it does not happen enough to really bother me. Infuse currently has alot more serious things to work on and fix right now.

It not my hardware, as i am using gigabit wired ethernet, and my media server is 12th gen Intel CPU, 32GB RAM, and 10gig NIC interface. Apple TV 4K 2022 model. Have not see the same behavior if i use the Plex app.

After more experimentation I’ve landed on using MP4 instead of MKV as the container. Was previously using MKV and keeping the raw audio stream and selectable subtitles. After converting audio to AAC at max settings while maintaining multiple channels and burning in subtitles I’m getting smooth playback, pause, and seeking.

Handbrake’s software x265 10-bit is still hit or miss, even in MP4, but using the h265 Videotoolbox 10bit settings produces visually lossless results that the ATV seems to prefer, at least with the current Infuse player.

While not a solution for everyone, this setup work great. Hope they prioritize x265 4K playback since for 4K it’s the most common encoder in the most common app that used to work.

Can you try playing these files in the new 7.7.3 update?

This update includes a number of improvements in this area, and your samples are now working as expected for me with this update.

1 Like

Yes. This solved the issue for me.

Thanks!

1 Like