Playback Stuttering... :-(

I have installed the new AppleTV App!

It looks great, but the playback very often stutters…!
I use a dlna-Server from my Mac (twonky)…

I have tried another AppleTV App (dlna Client) and there everything plays Fine without Stuttering!

Whats wrong with Infuse??

The files are Apple conform mp4-files, so no transcoding is needed…!

I also experience some stuttering which was not present on Infuse with ATV2. I have a 4K TV - is this perhaps the reason?

Same here, it is not a bandwith stuttering, loading time and timeline jump is really quick, the stuttering is unregular and minimal , i got a similiar effect when i turn off the 24p playback option on my panasonic bdt-500

Me too… apparently several times/second. Streaming with Beamer does’nt do this. I’m in Europe if it matters

yep - same here - its hard to describe - not smooth playback, looks like lost frames on fast movements here and there - definitely not a network throughput problem as plex or airvideo hd play the files smoothly on the apple tv from the same location.

Same stuttering here… I belive that the reason is that infuse is using its own player and not the native apple tvos player… that´s why the infuse player does not need to transcode/remux anything server side… but something needs tuning.

I posted this yesterday:

Do you use 50 or 60 hz? I had problems with stuttering in different apps when display was set to 1080p 60hz but switching to 50 hz made it way better.

I also experience small jumps every few seconds. I play my files from a synology nas with smb. My Apple tv is connected with the 100 base-t port to à gigabit switch. All my files are 1080p mkvs. I think we need the nfs protocol for smooth playback.

Tried both - Same result

There were reports of stuttering during the beta test, i was advised to try wifi 5gz (which i did but made no difference)

I purchased the app though as its a great product but I still believe this needs looking into.

The stutter issue i´m experiencing has nothing to do with buffering, ethernet/wirespeed/duplex or wireless frequence (that would all cause “unstable” playback).

The constant playback stutter iám experiencing has to be a framrate issue!

Source = 23.976
ATV4 = 50 or 60

To play source material with a different framerate than used by the playback device, you need to do some magic (pulldown, frame insertion etc.) as neither 60 & 50 fps is devidable with 23.976.

I have always used XBMC/KODI and always set the display refresh rate to match that of the source… but Apple does not allow any other setting than 50 or 60.

But Apples native player is really remarkably good at the “magic” framerate manipulation, and the Infuse player currently is not (i hope they will catch up thou, as i really like the infuse app)

I agree

Thats a bummer, that type of stuttering is really annoying. You might be right, maybe the native apple media player is better att adapting the framerate.

Lets see how kodi (mrmc) handles this when it will be available in the near future.

I´am only speculating offcourse, but playing back the same h.264 files, from the same NAS (no transcode) shows a very big difference - sadly in the native OSTV players favor, so I´am pretty sure that has to be the root cause… hopefully something the firecore team is able to address in a fix.

Same stuttering playback issue here.

I’m also experiencing heavy stuttering in a lot of mkv-files. Sometimes it happens immediately, sometimes after a couple of minutes. I’ve tried wired as well as over WiFi (5 GHz) but the result is the same. My aTV is connected to an amplifier which is connected to my TV. I’ve also connected the aTV directly to the TV but that setup also gave me the same stuttering.

My mediafiles are on a MacMini (2012) with OSX El Capitan. I’ve even disabled all other tools and utilities that were running on the MacMini but that also didn’t make any difference at all. I’ve tried streaming the files from a share on my MacBook Air, unfortunately still the same stuttering.

This is such a disappointment, I was so looking forward to Infuse! Now it’s back to plex for me until this issue will (hopefully) get resolved. If I can be of any help analyzing the problem then please contact me as I’m happy to help trying to solve this.

Same stuttering with infuse. No problems with plex for example.

I have also the problem.

When i play the video files over my Ipad / Infuse App / Arplay, the stuttering not present with this combination.

I think the Player in the Infuse App transcoding the video file and have frame drops from time to time.
I hope a update brings an improvement.

I might be wrong, but i dont think there is any transcoding going on. Only decoding.