Playback stuttering issue on iOS (AV1)

I have recently been getting playback issues when trying to watch a show that is encoded in AV1 - I have noticed it on some other AV1 titles as well.
It appears that at certain points, which are very repeatable, IE In a clip I have recorded showing the issue (I am a new user so I cannot upload it) I am able to get it to freeze at this point almost 75% of the time. This is happening across multiple files, and it occurs whether I stream it from my Jellyfin server or download the file and play it directly.
I have noticed on the web players, other media player, etc this issue does not occur. I have also tested the infuse app on the AppleTV and this does not occur.
iOS 17.3.1 iPhone 15 Pro - Infuse 7.7.4

If you are able to upload one of the problematic video files so we can test here that may help us better understand what is going on.

I have dropped a file showing the error along with one of the problematic files - please let me know if you need anything else.

I tested your sample here, and was not able to replicate any playback issues on an iPhone 15 Pro running iOS 17.4.1.

Can you try updating your iOS version to see if this maybe helps?

Infuse uses HW decoding for AV1 videos on iPhone 15 Pro. This is a fairly new feature for Apple, and it’s possible they could have fixed some bugs in newer versions of iOS.

Strange - I have gone ahead and updated the iOS to 17.4.1, tried clearing cache, re-installing the application, rebooting the phone, but still get the issue with infuse, but not with other apps using the HW decoding for some reason.
I also went to visit family this weekend and tried it on my dad’s iPhone 15 pro running 17.4.1 and it had the same issue - mine and his phone were bought at the same time so it could possibly be a chip or something was updated for future batches, but still seems weird.

Is there any built in logging or a feature I can enable for that to provide more information?