Playback Issues response Times

Ever since the recent app update put on the apple store my video playback has had a couple of issues.

  1. When pressing play it takes up to 15-20 seconds for playback to start.
  2. When using forward or back videos pause as if buffering for 5-10 seconds before restarting playback from new location.
  3. Some videos play normally then start playing like they are in fast forward. When it returns to normal sound is out of sync.
  4. Lots of start stop or small looping occuring. Some playback goes into a 2-3 seconds loop that has to be forwarded to continue.

System is AppleTV 4k Gen 2 connected by Ethernet to ASUS RT-AX88U asuswrt merlin router 1Gbps port streaming from 2 Synology DS218+ Nas units with 1GBPS SSD Drives and connected to ASUS router 1Gbps ethernet ports. Internet Fibre 1000/60 MBps

Can you try running a speed test for this share to see what kind of bandwidth you are able to get?

This can be done by navigating to Infuse > Settings > Shares > Share Name > Speed Test.

You may also try switching to Wi-Fi to see if things work any better.

Ok just tried and says speed is 520Mbps Minimum with Average of 523Mbps

Nothing has changed in the NAS side the only change before this started to occur was the update to 7.3.10 (4085). I havent got the beta installed yet am waiting for the testflight email from you with the link to authorise me to connect to the beta

What file protocol are you using with infuse?

Everything is MP4. I ran a defrag on my nas SSD Drives which took about 1 minute. Guessing not much fragmentation. Infuse is connected via SMB SHARE on current model apple tv. Everything runs on 1Gbos Ethernet using cat6.

I had my video format set to 4k HDR 60Hz so I have today changed that to 1080p 60Hz with match frame rate and range now turned on. Now just need to test some playback to see if anything improves

I have a Sony KD43X8000 2020 Google TV that up scales so prob don’t need the Apple tv doing the same thing.

Will let you know once I have a chance to see if any improvements

I think munpip214 was asking what file transfer protocol you are using for that share, like SMB, FTP, DLNA, etc.

Also, could you provide a screen cap of the graph screen on the speed test in Infuse after you run it through at least half of the movie? Just looking for repeated dips that may help figure out what’s going on.

SMB has always been slower than WebDav at least from my experience over the years using Infuse. With the WebDav service on my Synology NAS, I get full gigabit speed (940mbps) consistent. With SMB from what I remember, I get about the same speed range you are reporting. That’s a pretty big hit. Still, with 520mbps that bandwidth should be more than adequate to play movie files without any trouble. When I’m away from home and remote streaming on iOS devices or my M1 MacBook Air with a measly cellular data connection of say 10mbps, all of my 1080p and 4k files start with little delay and play almost instantly without audio sync issues when seeking forward or back. I run speed tests often on cellular to see what kind of cellular data connection works best - its takes little bandwidth with the right encoding. Without wanting to disclose my main source of movie files, all of my movie files are low bitrate/file size optimized for best quality encoded in h.264 and a few in h.265. Not that container should matter but most are mp4 and all of the 4k encodes are mkv.

Hopefully my experience can at least help with regards to knowing if bandwidth is the issue on your network.

Can you try changing the smb version from Auto to a different and see. Maybe to smb2 or legacy?

Right now it’s set to minimum SMB 1 and preferred smb3.

As I have said though I did not have this issue until the last tvos update of infuse 7. Prior to that it worked flawlessly and nothing has changed hardware wise even nas software wise

Thanks Derek. I have never used webdav is there anything I need to know about setting up and connecting infuse to use it?

SMB does need to stay enabled as I have a windows PC using it. I do use AFP for my iPhone, ipad and macbook and NFS for rsync copy backup to another old nas

SMB 3 will at times cause problems since it may have additional security packets that slow things down. SMB 1 is slow by nature. SMB 2 would be worth a try and also try the Legacy setting. The Legacy setting works better with some devices and is more compatible with them.

Try those two options.

There have been updates to help streaming issues that may cause a need to change the protocol you had selected prior to those updates.

If you have NFS setup already it is worth a shot. It should have relatively the same performance as SMB, but you don’t have to deal with all the different version issues that SMB tends to have.

But your issues seem really random and with the speeds you are already getting you shouldn’t have any problems. Did you try rebooting routers, NAS, and Apple TV?

And if you have time.

Yup have tried all that. And I agree it is random and stumped me hence posting it. Correcting a mistake I don’t have NFS running just RSYNC. I have installed/enabled webdav so will try that to see if there is any improvement. Maybe it’s SMB. I have often found throughput performance does not always relate to playback performance. Sometimes media files have been encoded with some weird codec or on a low performance device. If I ever come across them I run them through wondershare app on my MAC which re converts to mp4 with industry standard mp4 codec and problems are resolved with the file. But this happens on files I have watched before and they have been fine now they take 5-10 seconds to even start playing. Same for resume on FF/RW SKIP AND Will pause or go into a little loop of the last 10 sec or so when playing

Almost like the auto buffer is corrupt. Or the meta data maybe? I could try deleting meta data and letting infuse rebuild that. Not sure on buffer if it’s persistent across reboots or wipes or with this new optimisation on a different mode

If you are okay doing that I would recommend just deleting the app entirely and having it rebuild, in case the problem lies with the app.

Nope - Have deleted Metadata, deleted the Favourites, and asked infuse to Forget the share Added WEBDAV and added the folders I want to play as favourites (Temp for testing) then tried playing a couple of videos after the library stopped scanning, Same outcome…slow to start, looping, slow to resume.

In that case I would try messing around with the NAS, Ethernet cables, routers, etc. Maybe something else plugged in to one of those devices is causing the problem. Or maybe a cable went bad.