Playback issue with 1080p HDR/DV files (1st gen ATV4K)

Interesting thread, the problem seems similar, though what I played was not Netflix WEB-DL but an encode from UHD source, nevertheless it might be the same issue.

Do you have match content enabled and can you do a speed test? Also what kind of stuttering are you seeing and what type of files are these?

I just installed 7.3.4 on Apple TV 4K 2017 on iOS 15.3 and could confirm that I still see some severe stuttering on an 1080p x265 HDR file, noticeable from the first 2 mins. Both “Match” options are turned on and streaming cache is set to legacy. It it is not network related as I don’t have problems with 2160p remuxes with higher bitrates (or when something’s not working on the network, I get the buffering wheel). The file also plays fine on Infuse via iPhone over the same connection, but also on the LG TV player. I submitted diagnostics CY9GV right after playing it with stutter.
I also submitted the file to you via the Dropbox link (name that submitted will be Remus-CY9GV; file is Goodfellas.(1990).1080p.UHD.BluRay.DD+5.1.HDR.x265-DON.mkv). I then played it one more time and I filmed my TV (also uploaded the clip to dropbox: Remus-CY9GV.MOV); the stutter was not that bad as in the first attempt before taking the diagnostic, but it is still there and you can see the behavior around the 1:16 mark. I hope that all this data will help you pinpoint the problem.
To me it’s very isolated and this was the only file that had problems, probably some encode settings are not handled properly with the tvOS, nevertheless I would expect it to work it on the Apple TV too.

Thanks for the feedback.

We haven’t been able to replicate any issues like this here, and weirdly there haven’t really been too many reports of issues here. Normally, if a bug affecting playback appears we hear about it from a lot of people.

If you’re still seeing issues in 7.3.4, I have to wonder if there could be something environmental. EG A network issue, a bad install for a tvOS update, etc…

I know it’s not ideal, but if you’re in the mood it might be worth trying the following.

A. Delete and re-download Infuse
B. Restore the Apple TV and update it to the latest software

Did you check the files and diags I submitted already? This is not something that appeared now on 7.3.4, it was happening before too (7.3.2 I think it was the first time I tried to play it). And as I mentioned, it’s not a widespread issue since I only see it on that file, so I wouldn’t expect to hear it from lots of users.

Moved your post to its own thread, since it’s only happening with a single file and likely different than what the original posters were reporting in the 7.3 thread.

(The issue with threads like that is they kind of become a catch-all for any and all playback issues).

Ok, thanks, works better with it’s own thread. Let me know if you have any feedback on reproducing it.

It kept happening to me as well, AVC 1080p@30p, aac 2.0.

Diagnosis report: BYGWY

Wanted to follow up to check if you were able to check the files I submitted and reproduce the issue.

Hi, finally the issue is still happening with the last version.
Less often than in the previous versions but it happen some time still with HDR files.
I hope the “New, ultra-optimized playback caching method” in the upcoming 7.3.6 version will fix this

Today’s 7.3.6 did not fix the issue…

7.3.6 did not change caching behavior. This got pushed to 7.3.7

Still no better no result in the last 7.3.7 version…

@james Please check the video here : Imgur: The magic of the Internet

Netflix, Amazon Prime Video, VLC with HDR videos are playing correctly, and with Infuse all not HDR videos as well (4K DV, 1080p and others).

Apple TV factory restored

If you need other details, feel free to ask !

Please help !

1 Like

Just tried with Infuse 5 and file can be played smoothly !

1 Like

I can confirm that…every file that stutters in Infuse Pro 7 plays perfectly fine in Infuse 5!

I re-installed Infuse 6 and it plays smooth as butter.

Any news on this ?

The same file is perfectly read when I connect a USB key to the LG TV as well.

I’ve tried to change the Apple TV 4K video settings but nothing better regarding the playback of HDR files : it’s configured in 4K DV

@james , still didn’t fixed in 7.3.8 as you can guess…


Not better result with yesterday’s update,

You can find attached a txt file with 4 examples/files of media information : the first two are playing correctly but not the last two

I hope it will help, 10 updates later (at least) and I still have the issue - very problematic

INFUSE - HDR files.txt (8.0 KB)