Playback issue (random micro stuttering)

@speshe, yes, you are right and I was wrong above!

Changing 1080p@60Hz to 1080p@50Hz also did not solve the problem for me.
It seemed for a while that it did, but it did not. (Also 1080p@59,94Hz does not.)
The micro stutter just appears in a little bit different position…
The stutter does not always appear, that is what deceived me.

I find the above file (mythic.quest.s03e02.1080p.web.h264-ggez.mkv) very useful for testing. Because the micro stutter (frame drop) appears very often in the first 3 minutes of it! You can notice it around the wolf at the left.

Should I upload this file somewhere?
(Or you can easily download it with torrent, but it is not allowed to share a direct link to it here, in the forum. Maybe it is allowed in a direct message and/or in a support ticket?)

Okay, now I try to describe my problem again, based on posts of Sperious from these thread:

Because his english is way more better than mine and I have exactly the same problem as he had in the past.

My HW/SW environment:
Device: Apple TV 4K 1st gen and 3rd gen
Infuse version: v7.3.7 or later
tvOS Screen mode: 1080p@60Hz
Match Frame Rate and Match Dynamic Range: Both enabled
Network speed measured by Infuse at the used file: around 350 Mbps

Description of the problem (I only slightly edited it to make it up-to-date):
"
Infuse has been working great on my ATV4K forever, but since v7.3.7 I have seen random micro stuttering show up on everything I watch.

I have not changed anything in my setup. The ATV is set to match frame rate and this has worked perfectly. The TV still reports the correct frame rate. It is definitely not the source material because if I rewind and watch the very same passage again, the stuttering is not there.

Seems to affect all files I’m playing. It’s very inconsistent though.

Maybe this was introduced with an tvOS update, I’m not sure. It’s very inconsistent so it’s not easily detected but since I’m overly sensitive to the phenomenon I see it a few times per episode I’m watching.

I’m very confident the issue is not because of my setup. I haven’t made any changes to my setup in at least a year and Infuse has been rock solid for me. My Apple TV is connected to my router via ethernet.

I wouldn’t call my issues slow downs. It’s more like one single lost frame of video (audio seemingly not affected) at random intervals. Not very often though. Might occur once or twice during a typical 30 min episode.

This issue is probably hard to notice for most people. Not everyone is a videophile. It’s also easy to dismiss as something temporary. That’s what I did for a week or so, before realizing the problem is very real, and once seen can’t be unseen.

It takes away the joy of watching a good movie. I’m just looking for the next stutter.

I really hope there’ll be a fix for this.
"
So I have exactly the same problem!

Sperious also wrote:
“I have narrowed it down to being subtitles related. The stuttering appears at exactly the same moment that a new segment of the subtitles is displayed. Not every time, though. It doesn’t seem to affect embedded subtitles on Blu-ray rips, but it does affect external subtitles downloaded from OpenSubtitles and also subtitles embedded into mkv files.”

So his problem was related to displaying subtitles.
(And I think it was solved with v7.3. Form it’s change log:
“Fixed rare frame drops when using subtitles”)

BUT:
I also tested playing files without subtitles and I still get the random micro stutters.
So this is a different problem, only the symptom is the same.

Does this help? Can you try to locate and fix this bug based on this?

I also found this in v6.3.3’s change log:
“FIXED: Resolved rare cases of micro-stuttering”
What caused that problem?
Maybe that problem is back since v7.3.7 somehow?

I really would like to love Infuse again! :slight_smile:

Wasn’t really referring to the TV scanning frequency, was talking about the AT mains frequency. I know I’m coming from really old school, devices that use mains power and have frequency sensitive functions used to use the AC frequency as a reference since it was kept fairly accurate. Probably not an issue in "modern’ technology but just in case. :wink:

@NC_Bullseye, oh, I see! :slight_smile:
Yeah, the AT mains standard is 220V and 50Hz in Europe (and in Hungary where I live).
But that is not it. :slight_smile:

By the way today I tested my “old” Apple TV 4K 1st gen with my mothers TV which
is a different brand (and a very old model) and the random micro stuttering also appeared with it! :frowning: So it is for sure also not my TV’s fault.
(We watched Avatar.Extended.Collectors.Edition.Repack.2010.1080p.BluRay.DTS.x264.Hun-OnlyMux together and I noticed a micro stutter about 4-5 times.
My mother did not notice them at all, LOL, maybe it is my brain! XD
(But then I could not record it on video…))

Do you have any other suggestions to find and eliminate this bug?
Are frame drops registered in the diagnostic data?
Do you plan to develop a codec view function (also showing stream bitrates and dropped/skipped frames) during payback? Or would that be “too geek” for Infuse?
Every pro player I know has something similar, only Infuse not…

You can add your support to adding this feature here.

Don’t forget that you need to click the like button on the first post in that thread to show your support for that suggestion! :wink:

Just wanted to reiterate that the stuttering issue only appears when playing 1080p x265 HDR files. It does not appear when playing 4K x265 HDR files so I doubt it’s a performance issue but rather an issue in how Infuse processes those files.

I also think it is not a performance issue. But I have it with all videos, so for example with 1080p H.264 too…

Thanks, but I already liked that!
And it is waiting since more, than 3 years…

@james, Could you check this diagnostic data please?
9SV34
I started infuse, started to play a video until the first micro stutter (frame drop) and then I stopped it and uploaded the diagnostic data.

1 Like

I am not sure anymore if Infuse 7 is causing my current random micro stutter problems!
(In the past there were Infuse 7 related ones, but it is possible that they were solved with v7.4.6 (in changelog: “Improved video rendering performance”).)

I am thinking this because this week I tested 3 different Realtek RTD1619D + Android 9 based players:

  • Dune HD Pro Vision 4K Solo
  • Zidoo Z9X
  • Dune HD Pro Vision 4K Solo
    And all have this problem!

Then I re-tested it with my old HDI Dune HD Base 3.0 and even with MrMC on Apple TV 4K and neither can play the above Mystic Quest episode really smoothly! :frowning:
There are occasionally micro stutters, like in Infuse. But not always at the same point!
So it is not really reproducible. But often appears around the same points.

So now I am thinking maybe it is really my TV!
It is an old Android based one (Sony KDL-43W755C). Maybe some unnecessary apps got new version and one of them are causing this problem…
I am not sure.
I use Standard MotionFlow with the TV maybe the processing of that is somehow affected. :frowning:

You should have all motion processing disabled.

Sounds like a bad 6AU6 vacuum tube in the horizontal deflection circuit.

Yeah, you also might have to replace a couple 57nF capacitors. Just head down to RadioShack.

No, that feels terrible for me! :slight_smile: I am used to the Standard MotionFlow processing…

Motion processing can cause errors in playback.

I know.

But as I wrote above, I had no problems with Infuse 6 at all.
Using the same TV and AV receiver.

Had no micro-stutter at all for about a year…

Please read the full thread from the top!

By the way it is not the motion processing.

I tested everything with MotionFlow OFF and Film mode OFF and I still get occasionally a micro stutter (not reproducible of course).
But not only with Infuse, but with my old Dune and new Realtek + Android based players too.

Currently I am still suspecting my TV. But I am not sure.
I think I can’t avoid to factory reset it and then uninstall all unnecessary apps from it.
(It has an old Android 7 based FW, but Google Play Store still installs a lot of junk which I never use, because I use my Apple TV 4K instead of the archaic Android 7 sh*t, LOL.)

I was experiencing this today. Plex Media Server → Infuse on ATV → Denon AVR → LG CX. Watching Dolby Vision content in 24p, and it would stutter for a fraction of a second every minute or two. Looking at my Plex dashboard, it looked like Infuse would load the entire TV episode because network activity was very high for a minute or two and then went to zero (besides a few blips). So I knew it likely wasn’t network related. And almost all TV motion and processing was disabled.

However, I had ATV “Match frame rate” set to OFF, as a holdover from my previous attempts to fix the audio sync issues on the Plex app. So I had LG Real Cinema enabled for 5:5 pulldown for 24p content. When I set the ATV back to “match frame rate” (so my tv was refreshing at 24 hz) the issue went away.

1 Like

Well, that’s what match frame rate is for. If your atv is set to 60hz basic frame rate, as an example, and you play a movie of a different frame rate, you will experience stutters. So leave it on.