Playback issue (random micro stuttering)

@Axl2021, I also do not understand that after Infuse is copying the full video file to Apple TV’s SSD (when using the Auto cache mode), how can still a micro stutter appear?
A network problem can interfere into playback even in this case?
Apple TV 4K 3rd gen has a really powerful CPU with 5 cores, so I don’t really see how…

It’s easy to blame someone else’s network / disk equipment but if you read the wider forums this problem has been going on for over a year with multiple user complaints having no issues in infuse 6 release , hence the speculation that it is either a Apple TV os bug or infuse , I to have the exact same problem with micro stuttering on cat 6 hard wired network to a gen 3 Apple TV 4K on a wdmycloud with read spreads of over 300MB/s average. I am not a beta tester or expert with infuse but I would suggest maybe asking someone who may be more helpful in supporting you with working towards a solution

1 Like

There can be a lot of nuances. Without physical contact with your equipment, it is difficult to offer solutions.
Synology DS220+ is a good NAS.
I have used various options. And Synology NAS DS220+. And Keenetic KN-1010 + USB SSD. And distributed from two PCs: a mac mini m1 and an intel PC with Windows operating system. Everything was always fine.
Perhaps the NAS server will solve your problem. Will the disks also be new in the NAS ?

@speshe, you are right, I don’t think that it is not an Infuse problem, but I still will test the Synology DS220+…
Also @MrMacDaddio was not right above, because using newer generation of Apple TV 4K does not solve this problem at all (for me at least).
As I wrote, with Infuse 6 I had no problems at all. It is really a shame that it was removed from the App Store!
I do not need the new features of Infuse 7, I just need a player that plays any source flawless! Infuse 6 did that for me, but currently Infuse 7 does not…

@Axl2021 No, the disks will be the same SSDs. Samsung and Patriot ones. They work flawless.

You must mean someone else, I never suggested a hardware upgrade. I have not done that, but I do have mine jailbroken so I can revert to versions below Infuse 7.2, the app version when the stutter began. Even James confirmed this about 7.2…

But @MrMacDaddio, you wrote above these:

“[…] Apparently the 2nd gen 4k does not have this problem […]”

“[…] I am able to download an older version while we hopefully wait for a proper fix… not one that requires a hardware upgrade to the 2nd gen 4k. […]”

And I upgraded from 4K 1st gen to 4K 3rd gen and still have the problem.

So I think the 4K 2nd gen must have it too…

@Limpi exactly ! I have even demuxed a few files that cause the micro stutters and it does resolve the issue however these files worked flawlessly with infuse 6 I nearly upgraded to a synology to see if it helps so will be interested to hear your results although my best guess is it’s frame rate decoding issue that the last major tvOS update introduced

@speshe, I have this bug since v7.3.7 when the “ultra-optimized streaming cache” feature was introduced.
Best solution would be if Firecore could locate and fix the problem…
Meanwhile I red Synology DS220+ can not handle NTFS for internal drives, so I am not sure if I will test it, because my SSDs are all using NTFS and I do not want to reformat them just for this test…

And I also have this random micro-stutter problem when I use a Win10 Home 22H2 PC as Samba server. And all may cables are at least CAT6 too. So I don’t really think a Synology NAS would help with this. Data transfer rates are already far more than enough (370 Mbit/s)…

@Axl2021 and @james,
I could record a video of the bug!

Test file (playing on Apple TV 4K 3rd gen 128GB, but I have the same bug on Apple TV 4K 1st gen 64GB):

Playing the file with Infuse 7:
{Look at the wolf to see the stutter!}

Playing the same file with MrMC:
{No stutter on the wolf.}

DO NOT watch the above video files from browser!
You should download it and play it with a dedicated video player to really see the difference.
(Videos were recorded with an iPhone SE 1st gen.)

Speed test of the same file:
{Minimal speed: 361.76 Mbps}
{The real streaming speed of the playback is about 16 Mbps}

So I have stutters like this one since Infuse v7.3.7 (when the “Ultra-optimized streaming cache” feature was introduced). The problem is present with all cache settings (Auto/RAM only/Legacy).
Had not stutter at all with Infuse 6 and also not with Infuse 7 before v7.3.7.
Also I had/have not stutter with MrMC.

How can that be else than an Infuse bug?

I think I found a workaround!

It seems the problem is only present when I use the 1080p SDR 60.0 Hz screen mode
(and match frame rate on)!

It does not occur with 1080p SDR 23.976 Hz screen mode (and match frame rate off).
(I tried this because the MKV is 23.976 Hz. But tvOS menu is not smooth in 23.976 Hz.)

And it also does not occur with 1080p SDR 50.0 Hz screen mode (and match frame rate on). This is the default for my region. So I am switching back to this. (I originally changed it because 60 Hz looks a bit smoother in the tvOS menu…)

But it is still an Infuse bug, because with MrMC also 1080p SDR 60.0 Hz screen mode (and match frame rate on) works fine, I get no random micro stutters.

Maybe others having such stutters also used 60 Hz screen mode?

So now I am forced to use 50 Hz because this bug.
I will continue testing. I hope I will see no more stutters at all…

And why did you choose 1080p ? Do you have a TV that doesn 't have 4K support ?

Yeah, I have a full HD TV with max. 1080p SDR 60Hz resolution (Sony KDL-43W755C).
Please do not suggest next to replace my TV, LOL! :slight_smile:

I thinks it’s your TV :rofl:

I’d check your refrigerator.

Try to select the 1080p SDR 60 (59,94) mode and enable frame rate and dynamic range matching. This mode can keep the smoothness of the tvOS interface that you like and remove the problem with microfreezes.

I’m not 100% sure but I think I’d stick with the frequency that your country uses for AC power but that’s just old school vacuum tube theory passing through. :wink:

Just got the Apple TV 4K gen 3 128gb Ethernet model and the stutter is still there on 4k sdr 50hz and 60hz match content and frame rate gonna test 1080p next ….

@Axl2021, I tested that too, unfortunately it does not help.

@NC_Bullseye, I always use 1080p@60Hz on all my devices!
50Hz is the “official” TV standard in Europe, but I almost never use it.
I mainly play 23,976Hz (and sometimes 24,000Hz) videos and only very rare 25Hz.
Also match frame rate is enabled so the original screen mode should not matter at all.

On Apple TV, I like 1080p@60Hz because the aerial screensavers run very smooth on it (on 50Hz they run less smooth!). And also the tvOS menu and all apps run nice.
All apps but, Infuse 7! :frowning:
Also Infuse 6 worked for me very well in the same HW/SW/network environment!
I watched all seasons of Sons of Anarchy with it without a single micro stutter.
And also Infuse 7 worked for me well until v7.3.7, when this problem appeared for me.
(Nothing changed but the Infuse version and I also always use the latest tvOS version of course.)

So it is a bug within Infuse 7 or Apple messed up something in tvOS at about the same time as Infuse v7.3.7 was released. I am not sure.

And I understand that only few people have this problem (or only few are noticing it), but I think it still should be fixed!

@MrMacDaddio has it too and he can downgrade Infuse on his Apple TV to Infuse 6 and he does not have the micro-stutter then. (See above!) Please ask him for more details (because I don’t know exactly which Apple TV model and tvOS version he uses)!
But with current Infuse 7 versions, he seems to have the same bug as I.

Also @speshe has it (see above)!

Please help us, try to identify the problem and fix it!
I have this bug since 8 months. :frowning: It appears relative seldomly, but it is still annoying!
Since v7.3.7, Infuse has not silky-smooth playback for me! :frowning:
And I have a yearly subscription…

Sorry about my english, I know it is not perfect, I try my best! :wink:
I will try to describe the problem again in detail, maybe that will help you fix it!

I tried everything in my power, even bought the newest Apple TV 4K model because of this bug.

I would even buy the expensive Infuse 6 Pro Lifetime Licence if it would be still available in App Store and I would know it for sure that with it I can have random micro stutter free playback again!
(I don’t know why you removed it from App Store, especially that Infuse 7 is still having bugs. I think you should put it back into the store until Infuse 7 is really flawless! And Infuse subscribers should have access to both versions, That would help a lot until all bugs are fixed.)

Sorry about the long post, but I am really frustrated because of this!
(I even bought a new Dune HD Pro Vision 4k Solo media player just to test the Mythic Quest S03E02 with that too. And that produces no micro-stutter. Also my 12 years old Dune HD Base 3.0 plays it flawless. I find it nonsense that Infuse 7 can not…
Same TV, same network environment, same screen mode…)