Playback issue (random micro stuttering)

We’re not seeing widespread reports here, but would like to look into what might be the common thread here.

For those seeing issues, could you check the following:

  1. Apple TV model (EG A1625)?
  2. 32 or 64GB?
  3. Where are your files stored?
  4. Match Content enabled?
  5. Wi-Fi or Ethernet (does changing make a difference?)
  6. For SMB connections, does adjusting the SMB version in Infuse (try SMB2 or Legacy) help?
  7. Does adjusting the Streaming Cache option (Settings > Playback) to ‘Memory Only’ or ‘Legacy’ help?

For me:

  1. A1842
  2. 64GB
  3. On SSD drives
  4. Match Content is enabled
  5. Ethernet (makes no difference)
  6. Adjusting SMB version does not help
  7. Adjusting Streaming Cache option does not help

I also have a ticket for this:

Frame drops happen seldomly only with 1080p content since v7.3.7.
(I think most people are not noticing the seldom micro stutter,
so they are not reporting it.)

  1. A2169
  2. 64GB
  3. On NAS With RAID 5 + M2 Cache system
  4. Match Content ON
  5. ETHERNET
  6. Ajust SMB don’t affect the problem
  7. Ajust streaming cache don’t affect

As i Say its only for 1080p files x265

If i active Match Framerate 24P mode the playback work fine for 1080p x265

4K Files Work fine with 24P and work fine with no 24P

Plex have same problem.

I also have it with 1080p x264. But not with 2160p (which is downscaled to 1080p because my TV is 1080p). So all 1080p content have the bug, but not the 2160p content.

(I can notice about 3-6 drops in a 45 min episode, so for me it is seldom, but still very annoying. It is also randomly appearing, so if I rewind, the same drop does not occur.)

Do you plan to implement displaying of codec info in the future? Where count of dropped and skipped frames would be displayed too? That would help a lot with debugging such bugs. Also exact frameate (eg. 23,976 Hz), video/audio codec, used screen mode, etc. should be displayed…

I am also missing a System Info by the way, where CPU/GPU/memory etc. info could be displayed. Without System Info and Codec Info, Infuse isn’t really a “Pro” player… :confused:

Hi @Limpi i would like to know if you use Plex media serveur or a oser system for your library.

Me i am on Plex Media Server Version 1.27.0.5897 on Windows 11.

In the past before that i have an apple tv the server was on my NAS and some problem of PGS sub who burn my old NAS. So after guaranty i choosed to put my serveur on windows with link to nas directory where i have a 100% control of performance on system.

My old setup was Android tv box with server plex on windows and no problem to read any format.

I choosed Apple tv for a better sound possibilities and for certains app ex crunchyroll who don’t exist on LG store.

And what is the file system on your hard drives in the NAS ? I have encountered failures in the operation of Infuse with the ExtFAT file system. Infuse works best when the NTFS file system is on the hard drives

  1. A1842 (ATV 4K 1st gen.)
  2. 32 GB (18 GB free)
  3. The files are stored on a Samba Server 4.15.4 with ext4 FS on SSDs.
  4. Only Match Framerate is on.
  5. Ethernet (no difference with WiFi)
  6. SMB versions makes no difference (auto negotiation with Samba is protcol version SMB3_02)
  7. Changing streaming cache does not help.

I use Infuse only for streaming 1080p x264 content mainly at 23/24/25 Hz. Cannot reproduce this issue. Killing Infuse via long press home button helps.

Infuse build-in speedtest gives me around 400 Mbit/s. Don’t know if the ATV4K is capable of doing more on a 1Gigabit connection. The server and the network can definitively handle this 1G speed.

Not everything depends on the speed of your network connection. I was talking about working with a specific file system. Judging from your description, your disks do not have an NTFS file system. Change Ext4 to NTFS and try :slight_smile:

I have NTFS on all my disks…
And I had no problems before v7.3.9.
I also do not have problems currently when I use MrMC.
So I am pretty sure the bug is in Infuse.

@Webside79, I do not use Plex media server.
I use very old SMB protocols to connect (to one old Win10 PC and an even older HDI Dune HD Base 3.0 media player, both have SSDs connected).
But had no problems until v7.3.9.
And also have no problems with 2160p files currently.

I also found in version 6.3.3’s changelog (Infuse Release Notes | Firecore) this:
“Resolved rare cases of micro-stuttering”
I don’t know what that problem was, but maybe it is the one that is back since v7.3.9.

Or this one in version 7.3’s changelog:
“Fixed rare frame drops when using subtitles”
I always use subtitles.

Those two bugs were also within Infuse. I think this one is similar.

I was informed on one forum that infuse also works very well with the ZFS file system. Test it, maybe it will help

And if we change the protocols to newer ones ?

hi @Axl2021 ,

@Limpi and Me having some different configuration and type of library system.

Its logic to say that if 4k content (more big, more complex) work fine with infuse in any mode 24p 60p hdr dv sdr, its not a problem of type of hardrive, file system or other thing.

The problem concern only 1080p file.

The problem is not sur only by infuse if i reproduced the problem with Plex player.

Perhap a problem with TV OS. We don’t know.

Actually the only thing who work its put on Match FrameRate 24p from the apple tv for read with no error the 1080p file.

But i don’t love it because 24p create a short black screen delay before to start correctly due to transition 60p to 24p on receiver.

@Limpi exit that the source of problem is plex media library because it don’t use it. and SMB is not the problem too.

We must search among TV OS i think its for that speak with team of infuse is contructive idea for potentially find the solution.

Certainly it is not an underlying FS problem of the source server.

Regarding “Match Framerate”, for me I can say it definitvely happens when it is turned on. Because I don’t like panning stutter when watching 24p content on 50 or 60 Hz… :wink:

You are talking about different files, different codecs and different encodings. Those files that are encoded in H265 4K work differently from files in H264 1080p. And this is where problems may arise, including software in the FS line and other situations.

It seems I have this problem with all 1080p files (H264 and H265), but not with 2160p ones.
So regardless the used codec.
And have no problems at all with MrMC.
Before v7.3.7 I also had no problems at all with Infuse.

I gave you a couple of tips that may help you. Stop arguing, and just try. If it works well. If not, you will need to think further.
I’m not interested in how it works or doesn’t work on other platforms. If you like another player, use it.
We are talking about infuse here.

Okay, thanks for the suggestions! But I tried everything relevant months ago…
As I wrote, the bug is present for me since v7.3.7. Everything else remained the same!
So it can be only fixed by the developers.
If I could, I would re-install v7.3.6 until then, but of course that is no option on an Apple device… :confused:

If you can jailbreak the device you can use AppStore to downgrade your app. Unfortunately, there is no jb option for tvOS 15 so I stay on Infuse 7.1.3. I test every new version that is released but none have solved the stutter problem.

My downgrading of the app shows the SOURCE OF THE PROBLEM is Infuse and sadly they have not fixed it.

1 Like