Playback issue (random micro stuttering)

Yeah, I agree.
I really hope they can fix this in v7.4.4.
I do not want to buy the new Apple TV 4K model just because of this bug… :confused:

Beta testing of version 7.4.4 is currently underway. If you want, you can take part. At the same time, check how everything works and if anything, send a bug report to firecore.

Thanks! How can I participate in the beta test?
UPDATE: I found it. :slight_smile:

1 Like

Just to let you know that invites only go out on Fridays so you may be waiting for a few days

Okay, thanks!

Playback issue (related to SSD?) - #11 by Axl2021 - Check it out. This solved my problem. Who knows, maybe it will help you.

Make no sense to me for this thread as with this Finder/MacOS bug described in your link the file gets corrupted on the target. So the glitch/stutter is everytime on the same timestamp/position in the video file. But we here are talking about RANDOM micro stutters which occurs sometimes and which is not reproducible.

And I do not use Finder to copy the files. My video files are generated at my linux server.

1 Like

It doesn’t hurt to have the info here just in case others that may have posted here didn’t have the exact same problem as the rest of the posters. If it’s not applicable then disregard. :wink:

1 Like

Any news on this?
@james, are you closer to fix this problem?
I still have it, even with the latest beta version…

Maybe next version should focus to fix all bugs in the playback core!
Eliminating all micro-stutter bugs. For Apple TV 4K 1st and 2nd gen users too.

Maybe this helps a bit:

It seems I (with my Apple TV 4K 1st gen and 1080p SDR TV) have mostly the random (seldomly appearing and unreproducible) micro stuttering problem with 1080p [H|x]264 23,976 FPS contents, for example:
Resident.Alien.S02E09.Autopsy.1080p.AMZN.WEB-DL.DDP5.1.H.264-NTb

I do not have the problem with 1080p [H|x]264 25 FPS contents, for example:
The.Thief.His.Wife.and.the.Canoe.S01.1080p.AMZN.WEBRip.DDP2.0.x264-Cinefeel
I also do not have it with 1080p [H|x]265 25 FPS contents, for example:
The.Girl.in.the.Mirror.S01.SPANISH.1080p.NF.WEB-DL.x265.10bit.HDR.DDP5.1.Atmos-SMURF
Finally I also do not have the problem with 2160p [H|x]265 23,976 FPS H265 (HDR/SDR) contents, for example:
Evil.S03E10.HDR.2160p.WEB.H265-GGEZ
For.All.Mankind.S03E10.HDR.2160p.WEB.H265-GGEZ

So mainly 1080p [H|x]264 23,976 FPS has the random micro-stuttering bug for me.
The most common and most easiest playable contents.
I don’t know why.
Since Infuse v7.3.7. Had no problems before. (Also Infuse 6 played everything flawless for me.)

I have both of the Match Content options enabled.

I have several 1st gen 4k devices. The problem is evident with x265 encodes as well, most noticeably when I pause and resume again. I have another device with Infuse 6 on it and it plays everything “butter smooth” as they like to advertise. The problem somewhere manifested itself from 7.2 onwards. I have a jailbroken device so I can roll back to any version I want and this is what my testing revealed.

I have what I think is the micro-stuttering, the video seems to jump backwards and forwards for less than a second but continuously. It is on all the latest versions of infuse on my Apple TV and iPhone/iPad. It only occurs with files I have used Plex to record from free to air TV (Australia) which are .ts files. Using the native plex app or VLC the same files play perfectly. I have two iMacs set up as servers recording the same programs with the same problem.

If I demux the files (to trim out the beginning and end of the total recording so only the program is left) to mp4 then they play correctly (using Avidemux2.8.0.0).

This same process worked perfectly until the past month or so (I have been away from home for 4 of the past 5 weeks so I am not sure when it happened.

All devices are running the latest OS versions.

We have a potential fix which may help with the few reports we have seen here.

If anyone is interested in trying a beta via TestFlight please let me know.

Thanks, that would be nice! I am already beta tester, so I will test it.

What does the fix do? And why are only few users affected with this problem?

And is there any way to display the number of dropped / skipped frames or
I can still only use my eyes to detect them? :slight_smile:
If there is no way currently, do you plan to implement it? I mean some sort of codec info display.

Has started happening on my Apple TV 4K 1st gen with x265 files since I updated to TvOS 16 and latest version of Infuse.

A post was merged into an existing topic: Infuse 7.4.6 (4263) beta 2

A post was merged into an existing topic: Infuse 7.4.6 (4267) beta 3

I think the newest version (7.4.6) finally solved this! :slight_smile:
I get no more random frame drops at all (or only extremely rarely).

But it was very disappointing that fixing this bug lasted more than a half year… :frowning:

Solution / Workaround -
use Avidemux which works on Mac and windows to convert the MKV to MP4 just select copy on both settings and MP4muxer as output and it does not transcode so keeps the same quality without converting I have tested on 3-4 files that would always glitch and go green and pixelated and this has solved it. use mediainfo app to check which videos need demuxing I find its mainly the MKV HEVC files with 23.976 fps

I love infuse but guys this has been broken for around a year and if its not addressed I worry customers will jump ship to alternatives that are more stable and don’t require a subscription i.e MRMC

Sadly extremely rarely I still have this problem with my Apple TV 4K 1st gen!
It is not reproducible because it (a frame drop or skip) happens only 1-2 times in 1 hour of video.
I think upgrading to Apple TV 4K 3th gen would completely fix this problem.
But I still hope it will be solved within Infuse somehow, because I didn’t have it at all in version 6…