Playback bug with some BDMV files

Hi James. I confirm the presence of a bug.
This happens on movies with a BDMV structure on m2ts files.
I have not seen this on mkv files. If you repackage a movie from ts to mkv, everything works fine.In addition to the fact that microfreezes happen, sometimes the movie stops and infuse gives an error.
The film Oppenheimer infuse does not allow you to watch to the end. There are a few minutes left until the end of the movie and infuse gives you an offer to watch the next movie.
And also, in the same movie, infuse incorrectly defines the language of the audio track. The second track is in Russian, infuse says it’s in Spanish.

Code 3KV4H


https://cloud.mail.ru/public/udwe/cMrVSPNbo - stopping a movie with an error and offering to start another one.

2 Likes


Sometimes after rewinding it shows this error. After which infuse exits the film.

1 Like

@james hello.
Please tell me, have you been able to reproduce the described problems? Should we expect to fix these bugs in infuse 7.7.4 ?

1 Like

@james hello.
I began to encounter similar bugs already on all m2ts files. Even those that have not been changed. I tried to delete infuse, clean the cache. Nothing helps. I tried it on three different Apple TV devices. 1-3 generation of 4K set-top boxes. There are bugs on all of them.

1 Like

Update.
I’ve tried several network protocols.
Microfreezes, infuse crashes occur when pausing/rewinding with m2ts files with FTP/WebDAV protocols. When using the SMB protocol, none of this is there.
But the bug with the inability to watch the Oppenheimer movie and the incorrect definition of the audio track language persists with the SMB protocol.
The WebDAV protocol is important to me, as I connect to my Synology NAS from different addresses in my city.

1 Like

@james hello. Have any news ?

Hi @james. Are you looking for a solution to the bug?

@james, hello.
Have any news ?

Yes, there is such a thing: when connecting via WebDAV, rewinding in m2ts files, the Infuse application may freeze.

There is no such problem when browsing via SMB.

1 Like

Are you able to send in a video sample we can test here?

@james hello.
I just uploaded a video file named H264.m2ts.
A little later, when the segment from the video file with the H265 codec is ready.
For video file H264 code: H7V52.
As I found out earlier, when fast-forwarding and rewinding, the image freezes, sometimes infuse gives an error and the application closes.
This happens on all three generations of Apple TV 4K.
The bug occurs on the FTP/WebDAV network protocols. On all types of video files in m2ts format. I tried both infuse 6 versions and infuse 7 versions - there is a bug in both.

Code for file H265.m2ts - 1DV2P

And here is this code: S4JVW.
At this moment, when rewinding the full movie (from which a piece of the H265.m2ts file was taken), infuse throws an error and closes the viewing. As it was in the screenshot above with the film Oppenheimer. And this happens not with some m2ts video files, but simply with all of them that you can’t run in infuse.

James, did you receive samples of video files? Were you able to reproduce the described bugs?
I can cut off 50 gigabytes. Or, if you give me the opportunity, I will upload the full video file (70+ gigabytes).