Photo's not showing

Hi all,

Hopefully somebody can help me out here. I have a lot of family photo’s on a NAS disk which I would like to be able to show using the media player. I do see the folder structure and the several jpg files (showing a standard thumbnail). I am unable to load any of the photo’s. Trying to look for an answer but could not find it. Is there a max size for the jpg files before they show up? Or can this not be done?

Thanks for the reply,


maybe you just need to be patient - the media player seems to be awfully slow when it comes to photos. If you have many photos in one folder it can take really long time to show the photo you select. Have you tried with XBMC ?

Phew, glad its not just me!


Same issue. Movies stream & play OK. I can see all my Photo albums and thumbnails within. When I come to view a slide show for example, I just get the spinning loading disc. I have been VERY patient and waited for 10 minutes. I reckon that’s enough waiting.

Any clues?


FWIW. Windows 7 64bit, i7 920, 6GB DDR3 RAM. aTV connected via Ethernet directly to my Apple Extreme Base Station. My PC is also directly connected to the router.

Hmm not the answer I was hoping for  :frowning:

Have been VERY patient as well. Hopefully somebody can help us here (or fix this)!

Given up on Plex. So dog slow. Can’t view photo’s. Might as well just AirPlay my camera roll to the aTV. Removed Plex from my PC, iPhone and aTV.


I will try it again (perhaps), just fed up trying and getting no where for now.

Improvements for photo viewing are in the works.

Stay tuned.

thanks, will do…

Okay, thanks.

Any update on this? Photobrowsing is incredibly slow for me. Is there anyone else having issues with browsing your photo library?

I’ve got same issue. A hard drive with loads of photos that media player won’t load. I can see the files within their folders, but when I select a photo to view, a screen shot of a faded grey cinema ticket shows - not my photo!

Films are no problem, but photos don’t load.

Can Firecore please resolve this?


Hmm, are these photos relatively large in size by chance? I believe there is a limit on photo size right now, but I recall it was set pretty high.

Hi James, thanks for speedy reply. The photos were taken on my camera phone. I have an iphone 5. I’m unsure of size, but will be a little disappointed if Media player cannot handle simple camera phone photos?!

I had a simelar problem Thumbs are showing but the lage pictures aren’t. I removed the photo’s library and created a new one, this seems to be the trick for me.

In my case nothing is helping. Recently created new folded on SMB server (windows 7) and copied 1100 photos inside (majority iPhone 6 taken). Unfortunately only some photos are loading (very slow) remaining are not loading and the “stamp” with Firecore ADMIT ONE is displayed.
Please help - how to start?

Three years on and still not working. No solution from firecore.