Permissions on External USB Drive

I'm trying to manually move files to and from the External USB drive attached to the ATV (with Cyberduck), but the USB drive has the little red "no entry" sign, indicating I don't have permission to do anything.  I tried to change the permissions using Batchmod for the whole drive while connected with Cyberduck, but it doesn't seem to take.  Any suggestions?

Are you accessing the drive through the Movies folder or through some other means?

You may also try refreshing the folder listing in Cyberduck to see if that resolves the issue.

I have the same issue. I login to AppleTV via Cyberduck SFTP. I then go to Volumes and select my external USB hard drive. I try do drop new movies to it, but it doesn't let me make any changes to the drive due to the permission that I don't have . I get the following error with Cyberduck: SSH Error: Upload failed Permission denied (SSH_FX_PERMISSION_DENIED: The user does not have sufficient permissions to perform the operation.).

I also tried Batchmod, but it doesn't change the permission on the external USB hard drive. I tried following terminal command line which supposedly changes the permission to OSBoot drive: sudo mount -uw /  This didn't help either.

Is there any remedy to this with a terminal line or anything? All we are trying to do, including the initiator of this post, is dropping files to the external USB drive that is hooked up to the AppleTV.

 

Thanks!

You won't be able to transfer files directly to the drive, however you will have an 'alias' visible in the /Users/frontrow/Movies (or just /Movies if connected via FTP instead of SFTP) folder.

Using this alias you can view the files that are currently on the drive and transfer media back/forth.

I too am having this problem. If I disconnect the External HD from the AppleTV and attach it to my iMac I can transfer movies and they play OK when I reconnect the XHD to the ATV but I cannot transfer files via FTP due to permissions errors. This is getting extremely frustrating and I’m thinking I’ve wasted money on an app that doesn’t work as advertised.

Still no feedback? I have had the same issue for over two months now, with absolutely no luck! 
ATV1 - latest ATVFlash (purchased and downloaded through your site)

1.5 T external drive connected via USB

Content is available over the network via SMB and UpNP

… that said, I can not transfer or delete files at all. I have done SSH I have done FTP, I have done access via Volumes, and via /Usr/frontrow/Movie/ 

ALL GIVE A PERMISSIONS ERROR. 

Please respond with a solution.