Pausing/Buffering During Playback

Since the latest update I am having a problem with videos pausing to seemingly buffer for 15 seconds to a minute every 5to 10 minutes. They are playing from a Windows 10 SMB. They are mkv rips of blu-rays.

Playing the same videos direct streaming from Plex, Emby, or MrMC does not have the problem so I am assuming it is an Infuse problem.

Is there anything I can do to help get this fixed?

Same here. ATV4, Windows 10 media workstation. Happens over Ethernet or 5g WiFi network.

Via Ethernet a blu ray mkv will start playing for a few seconds and then bufffer for 20 seconds. Happens on chapter skips too.

Via wireless a bluray mkv will start and chapterskip normally, but then randomly buffers a movie (every 20 minutes or so).

The only change to my setup was upgrading the media PC OS (win8 to 10… clean install) and I thought the buffing issue had something to do with that… didn’t realize Infuse was updated recently until I read your post.

If you have a chance to send in a report from your device we’d be happy to take a look into this.

I’ve submitted the log with code 1ZXP6 and sent a support email - ticket 96551.

Thanks for looking into this.

I sent mine off as well… tech support case number 96554.

I uninstalled and reinstalled Infuse yesterday and it worked just like it used to… and then today the buffering issue returned.

Any update on this? Infuse is basically unusable for me since the last update. Is there a way to go back (I doubt it but thought I’d ask)?

FWIW, here’s what I did…

  1. Purged all Metadata
  2. Uninstalled Infuse
  3. Switched the ATV4 from Ethernet to WiFi
  4. Power cycled all my networking equipment
  5. Reinstalled Infuse and let it repopulate ALL of the metatdata before I did anything else.
  6. Finally, made some performance tweaks to Win10… in particular adjusted the power save settings on my media drives (go to your power options, set to high performance, go to advanced and make sure your drives never sleep… type in “never” where it likely says “20 Minutes.” I also turned off drive indexing and disabled a few services).

The above has eliminated the buffing issue over WiFi! So far anyway… still waiting for the dreaded buffering to happen during playback. Prior to the Infuse reinstall, over WiFi it would buffer a BR rip after about 20-30 minutes in… and then every 20-30 minuets after. Really long buffering too (minute +).

Via Ethernet I still have the same issues… plays for a few seconds when the movie starts and then buffers for 20 seconds… after that is seems ok, until you do a chapter skip and then the same thing happens.

I’d prefer to have this hooked up via Ethernet, so I am keen to get a reply to my tech support email.

I’ve power cycled everything but still have the problem. I’m just not willing to change my whole setup just for this version of Infuse when everything else is playing fine both streaming and locally using other apps.

Purging metadata and reinstalling Infuse is an inconvenience and it takes time to rebuild the library, but for me it helped so it was time well spent. I get that switching to WiFi may be an issue, but it doesn’t take but unplugging the cable and restarting your ATV4 to test if it improves the buffering. FWIW I was impressed with how much faster the ATV4 is on a 5G network (I swore by the mantra of “hardwired connection only” prior to testing).

That said, I’d still prefer a hardwired connection for a variety of reasons so I ultimately want that issue sorted, same as you. I hear the ATV5 is due to drop in Fall… I would hope they upgrade the Ethernet to 1G!

…and I am back to random buffering on movies over WiFi. Happened on three separate blu-ray MKVs (each stored on a different hard drive… all SATA connected 10K Barracudas). Now it can’t play several minutes without buffering. Not sure what the connection is to uninstalling/reinstalling Infuse and having it work OK for a few days, but I am right back to where I started from. Very frustrating, particularly because it worked so well before.

I feel as if I have done all the idiot checking I can do at this point. Not sure what else to check w/ my setup, particularly because it worked flawlessly before I changed to Win 10. If this is a bug, I’d love to know because I can wait for a fix. If it something with my setup, I am not sure what else to try @ this point.

Is there any update on this issue. I basically have an unusable product that I have paid for since your last update.

Yeah, it would be great to get some feedback either here over via the tickets we opened.

To the devs, this is what I have found in my constant troubleshooting:

If I restart the Apple TV though the settings > system menu, the issue goes away for several days (or after playing several movies)… then the random long-buffering starts again. Then I restart the Apple TV and the problem vanishes (for a while anyway).

I am not sure what exactly the Apple TV does during a restart process and how that impacts Infuse - Flushes a cache? Resets it’s connection to the network? - but whatever it does, it resolves the problem for a short time.

I am half tempted to totally reset my ATV4 to factory and rebuild it. It would be a pain reloading all the apps, but it would satisfy my curiosity to see if it addresses the problem for good.

I’ve have tried today’s update 5.3 and am still having the same issues.

This is going on a month now for a program I paid a subscription for and is currently unusable. It was working 100% find before the 5.2 update. I am not happy about a bug being introduced and the apparent lack of a fix.

I have tested now with the latest update and tvOS11 and am still having the problem introduced with the 5.2 update. I am getting no response on my support ticket for 22 days now. The app is completely unusable to me.

How does one get a fix or a refund on Infuse?

Infuse 5.5.3 stutters and stops after 4sec. when playing Jelly Fish, HEVC, 10bit, 20Mbps, under tvOS 11. Version 5.5.2 played relatively well under the last beta of tvOS 11.

Using 5.5.3 and TVOS 11… buffering issues still persist. I went so far as to do a clean reset/reinstall of the Apple TV4, bringing it back to factory. Buffering issues still persist. I used Hard Disk sentinel to review real time disk performance of my hard drives during buffering issues… drives are fine and the read/transfer rate is consistent. All networking gear is power cycled all drivers updated. At a loss @ this point… would be happy to try a beta.

We’re looking into a few cases of this. Sorry for the trouble.

I just got a new Apple TV 4K. I will retest on that to see if it is hardware specific and will report back.

If nothing else, the ATV4K has a Gigabit Ethernet port which has provided super-fast performance in our tests here. ~30GB MKVs start virtually instantly. :slight_smile:

The problem doesn’t seem to be an issue on Apple TV 4K. It normally showed up within the first 10 minutes of a movie. I let one play for a good 30 minutes without trouble.

Also, chapter skipping is much quicker. On the down side the blacks seem a bit too black. I have my ATV in SDR mode so I don’t think that is it. Playing the same content in Plex on the ATV doesn’t exhibit the problem.