Passthrough not available in tvOS 11.3+ (Solution: Use 'Auto' instead)

Still no DTS sound on just public released tvOS 11.3.

I was hoping that it will be working since it did not during the betas.

Did you check to see if you still had “auto” selected in Infuse and that tvOS still had “Best Quality Available” selected?

In Infuse on “auto” I get dolby digital from an DTS track, change it to “passthrough” and get the noise. tvOS has “Best Quality Available”.

Firecore recommends that you have “auto” selected in Infuse and that tvOS have “Best Quality Available” selected for the best output.

They have a page that goes into the audio setting a bit that may shed some light on what you’re looking for. https://support.firecore.com/hc/en-us/articles/217735707-Audio-Options-tvOS-

1 Like

There are a few issues we were hoping Apple would resolve before the release of 11.3, and unfortunately this is one of them.

We’re looking into potential workarounds for this, but for now you can set to Infuse to Auto and the Apple TV to either Dolby Digital or Best Quality Available to at least have audio working. In fact, this will allow you to have higher quality audio in some cases.

1 Like

Thanks for the reply James.
Ok… lets see if future releases of 11.3 fixes this issue.
I’m a big fan of DTS and have many flicks and some DTS music audio files that I was seeing the magical “DTS” logo on my Home Theater receiver using with Infuse.
I did manage to get PCM displayed on my Home Theater receiver by doing some tinkering in the audio settings via optical on my LG TV.

Is there a petition somewhere to ask Apple to do a real Passthru bypassing the original audio unchanged to the amplifier ?
Is that so complicated ? Every cheap boxes or consoles games does it for ages without any issue !

1 Like

…same here. Setting sound to ‘Auto’ in Infuse when playing a DTS movie gives me Dolby Digital which is sort of ok, but then, that’s no “Throughput”, is it, as I’d like to have my DTS back. If I set Infuse to ‘Throughput’, all that I hear is noise… what gives?

If you set the Apple TV to ‘Best Audio Available’ (or something similar) and Infuse to ‘Auto’, Infuse will decode everything and pass it as LPCM. This is lossless process, so the only thing you’ll be missing out on is a light saying AC3 or DTS on your receiver, but it’ll be exactly the same audio with nothing missing.

…unfortunately, that’s no option for me as my AV receiver is not capable of playing back multi-channel PCM!

I have to admit that the main reason I like passthrough is that I see DTS 5.1 displayed on my receiver. It also feels better to not let the Apple TV do decoding that my receiver can do. But yes, both are not very good arguments.

That glorious [DTS] logo!!!

I’ve just asked Apple for a full passthu audio feature that bypass completely the audio stream unmodified to the amplifier.
You can do it here:
https://www.apple.com/feedback/appletv.html

3 Likes

Did the same.

Ah, good to see that I am not alone with that problem.
I also switched to “Auto”, so the workaround works (but is no real solution…)

Let’s hope that Apple changes this again in the next update!

…also provided feedback on the Apple TV support page. Let’s hope that we’ll be able to see the DTS logo lit again soon ;-))

Same problem here.
Disaapointing

Same problem here. No DTS. meh…

Infuse is getting worse with every ‘update’ from Apple…

Just figured out you can’t roll back to a previous tvos version on 4K appletv (thank’s apple for removing the usb port, -what a vice this company has for removing ports that actually are there for a reason-).

If this doesn’t get resolved soon, I will be switching back to Plex.