overflow errors in new beta

Overflow used to work great. I installed the latest set of updates along with media player .6. Now menu items set to overflow  appear in the regular menu bar and in overflow. Basically overflow no longer removes the menu item from the main menu bar.

I uninstalled overflow, rebooted and reinstalled it. The problem persists.

I am at the latest Apple release installed with season pass and all ATV2 updates.

Suggestions ?

 

 

Overflow is working as expected for me.   Not sure why you should get different results.

Same errors and troubleshooting as labenski above. Are there prefs that persist through uninstall?

I have just run a nitiTV update, and thatb seems to have broken Overflow which was working fine prior to the update.

Having the same issue.  ATV2 fresh out of the box, Jailbreak with sn0wbreeze, updated nitoTV, installed overflow.  Items are added to overflow menu, but not removed from main menu.

Guess I’ll do a restore and fresh jailbreak and see what happens if I don’t update nitoTV

I’m having exactly the same error - items in the Overflow menu still appear in the regular menu. Does anyone have a fix?

–todd

OK, some some more testing last night.  Again, I am using Sn0wpass instead of Seas0npass, but was having the same issue.

So, I pwnd, and installed the jailbroken ipsw.  After booting, went straight to nitoTV, installed overflow, and moved some menu items.  Everything worked as expected.  I then did an ‘update all items’ from the nitoTV install menu, and went I went back out to the main ATV menu, all my overflow items were back, as well as showing in the overfloe menu.

So, it appears that the issue is with a recent update to one of the packages in nitoTV.  I’m going to go back tonight and track down which packages have been updated since the current Sn0wbreeze release, then see if I can update them one at a time and find out which one broke Overflow.  I’ll report back if I find anything.

Till then, seems the best method is to NOT update NitoTV from the default install.

I updated my aTV2 this morning, and the exact same thing happened to me, so I’d like to add my +1 to this problem report for a speedy solution… :stuck_out_tongue:

However, I have more to add to this discussion that simply my +1; being a Linux System Admin by trade who loves Debian - I perform my aTV2 upgrades on the command line so I have a much better idea of what exactly was upgraded that may have caused overflow to no longer be able to remove items from the main menu when they are moved to the overflow menu:

aTV2:~ root# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  cydia
The following packages will be upgraded:
  beigelist berkeleydb com.whatanutbar.exposed org.tomcool.smframework sqlite3-lib uikittools unzip wget zip
Now, when I browse the package descriptions for overflow I see:
# dpkg -l | grep overflow
ii  org.tomcool.overflow          1.1.0-1             Think Categories for AppleTV
ii  org.tomcool.overflow.tweak    1.0.0-7             new beigelist compatible 4.1-4.3 and support
The description of org.tomcool.overflow.tweak seems to imply a dependency with beigelist, and beigelist was in the list of packages to update from the output of `apt-get upgrade`.
I wonder if beigelist needs to be rolled back, or perhaps ultimately we'll need to wait for an update to org.tomcool.overflow.tweak to make it work properly with the latest beigelist?
In the mean time I have used the limited ability of the aTV Flash (black) Settings menu to hide a few of the superfluous menus (Movies & TV only) until a proper fix is available.
My $0.02.
-D.

I just came home from NYC on vacation and decided to reflash my ATV2 with the latest firmware… Havn’t been to much into updating because the thing just worked. I am in the same situation.

I register the same issues with these versions:

ii  org.tomcool.overflow            1.1.0-1             Think Categories for AppleTV

ii  org.tomcool.overflow.tweak      1.0.0-7             new beigelist compatible 4.1-4.3 and support

… I did however fix it :slight_smile:

The culprit is beigelist. Downgrade beigelist to version 1.0-1 and all seems to work.

 

UPDATE: Just run the command # apt-get install beigelist=1.0-1

Apt will simply downgrade beigelist.

— old post —

I did this by first uninstallting beigelist. It will remove alot of other stuff. For me it took out com.firecore.maintenance com.nito.nitotv com.plex.client-pluginorg.xbmc.xbmc-atv2 so I also installed those afterwoods. But please copy a list of what it removes so you can manually install them again afterwoods.

Here was my steps.

1: apt-get remove beigelist

2: apt-get install beigelist=1.0-1

3: apt-get install com.firecore.maintenance com.nito.nitotv com.plex.client-plugin=0.0.8.0.RC2 org.xbmc.xbmc-atv2

(I took note of those when uninstalling beigelist, the plex version added during step 3 is because I use the 0.8 RC2 version. If you use the plain 7.1-1 version, then just skip the =0.0.8.0.RC2 part)

— old post —

And then it worked. Do this at your own risk :slight_smile:

Hope this helps others.

 

Regards Mark

Thanks ! now it works like a charm. I connected via assh and …

Just run the command # apt-get install beigelist=1.0-1

after the update rebooted atv2 and all is well


Mark - 

I followed your directions - it took out nito, plex, and xbmc, but I reinstalled them and everything is up and running and looks great again - many thanks!

-Todd

Your welcome :slight_smile:

Easiest way is though the updated way:

UPDATE: Just run the command # apt-get install beigelist=1.0-1

Apt will simply downgrade beigelist.

 

Just wanted to help others :)

- Mark

This method no longer works since I updated with the new Seasonpass today. Does anyone know a solution to get Overflow working with the latest firmware?

Overflow needs an update to be compatible with the new Beigelist which is required for the 4.3+ AppleTV software.

No way around it at the moment.  :frowning:

Does anyone know how we might be able to reach out to the author of Overflow??

I’m noticing that links to the project page (http://appletv.tomcool.org/overflow ??) are now dead and returning 404 errors (not a good sign…)

At this point in time the latest ATV2 jailbreak environment has been rebased to remove to last version of beigelist that Overflow has been known to work with. Rather than focusing efforts on going backwards in time to solve this problem (which is a bandaid fix at best), we need to figure out how to update Overflow so that it supports the latest changes in the beigelist API.

If the original developer has pulled up anchor and sailed away, then someone else is going to have to pick up where they left off… :/ I have the ability to help, but not necessarily the time… how does one get involved in the atv2 software dev community anyways?? (any suggestions?)

I believe that I speak for everyone on this thread when I say that Overflow is a very simple yet vital piece of J/B functionality that helps keep the clutter out of the AppleTV UI. Certainly there must be a way to dust it off and save it.

Regards,

 

-D.

[w] http://fixthecode.ca

Overflow is open source and can be found here: https://github.com/tomcool420/Overflow

Hope this can help with the reimplementation.

Anyone have and further information on an update or alternative to overflow?  I can’t stand the mess of menus - need an update to the great add-on…

Any news about this? thanks

Not sure when it was pushed out, but Overflow has a new update, available through nitoTV, that fixes its issues. Stoked.

Really?!? Well this is good news indeed then as I have been holding off on updating my atv2 to the latest firmware until this issue has/had been resolved.

Thanks for the heads up mrhunt!! 8)

-D.