OS X 10.4.11 + unable to partition. diskutil returned 1

When trying to run the aTV Flash verbatim after utilizing disk utility to erase the drive, I get an error message at “start” stating “Unable to partition. diskutil returned 1”.

I tried to search the forum for anyone else experiencing this particular scenario and didn’t see any references.

Any help would be greatly appreciated and thanks for your time =)

BTW: I’m using the same media that was sent to me on purchase…Memorex traveldrive 2.0 256mb

Oops…I think I posted this in the wrong category…

Please email us at: http://www.atvflash.com/contact.php

Im getting the same error message

“Unable to partition. diskutil returned 1”

What is causing this and what is the solution ?

I have the same issue same error code returned. I am at loss what to do.
I searched the net located the link to install boxee on a usb stick http://gizmodo.com/5082130/how-to-max-out-apple-tvs-potential-with-boxee and was able to install this patch on my USB stick and then run on my ATV .

Why mention this? Well it has the same similar set up to aTV Flash and issues regarding a USB drive. Why do I get an error message Unable to partition. diskutil returned 1.

I really would like to get my aTV Flash installed on a USB stick any other thoughts what I may be the issue, tried over 6 different USB sticks including some recommended here

Solved the problem !
The problem was the OSBOOT File 2Z694-5573-24.dmg linked from the PDF on the read me first page
Issue solved when I downloaded directly using the link from one of the posts on the Forum