Original Apple TV features disappeared


I use SeasOnPass first to jailbreack my Apple TV and I use it again to get it started with a tethered boot.

Then I installed aTV Flash and everything worked well.

After that I moved the Apple TV to another room so I’ve been forced to disconnect the power cord. So, once in the new room I restarted with a tethered boot (with my iMac connected) and after that I simply disconnected the USB cable to connect the HDMI to the TV.

Again, it works, but all the original Apple TV features disappeared. I can only see the Firecore and third party apps in place. 

What’s going on? I tried more times to reboot and even to re-install aTV Flash, but nothing.

Suggestions by your side will be really appreciated.


Thanks in advance,


Are you sure ALL the standard ATV icons disappeared? If so I have no idea what is happening. However if the Settings app is still there you might want to check if the network is active? Many icons only show when the ATV detects a working network connection.

Of the original Apple ones I can only see “Computer” and “Setup”.

The wireless network settings are ok, I can browse the Internet and I can access all of the iTunes features and all of my movies which are stored in an external hard drive connected to the iMac via USB.

The missing tabs are Youtube, NBA etc.

All the above is really strange because all my setups are still there, even if I disconnected the line power to reboot in another room after one night discovering what was working well in the evening doesn’t in the morning after.

Anybody experienced the same issue ?


I just did.  It was fine last night, powered it all off and went to bed.  Came home from work today and nothing but the ATV software is there, nothing of the normal Apple TV software like Hulu Plus or Netflix or iTunes…it’s all just ATV.

It is worth checking that the network connection is still working.  This is the sort of symptom that one expects to see if the ATV thinks the network is down.

Same here. Im running 5.0.2, was working fine yesterday. Today i couldnt start anything in netflix. Rebooted the ATV, and voila all original apps are missing.

I’ve opened a ticket about that.


Now I need to check everything again, even if I’m pretty sure nothing has been changed but the room where the aTV is located.


I’ll keep you updated.

Hello again,


well, unuseful to say I tried several times to solve this problem by re-jailbreacking and re-installing aTV Flash without success.


But today I have an update, a good one:

After being upset for what was happening, I dropped the work with the Apple Tv.

Today, after 2 days I left the Apple TV on the desk (connected, untethered boot done, in stand by) I tuned the TV on the HDMI port which the Apple TV is connected to and… with great wonder, everything was in place like the first time (before the bad behaviour).


Now, it’s quite difficult to say what’s happened as nobody touch anything on the hw side as well on the sw setup one.


Let’s consider this issue solved (for the moment), even if we can’t say how.

I will keep the whole system under control in the next days, trying to understand the details.


If I won’t post anything else about it, that mean it’s definitively ok.


Thanks anyway for all your efforts in helping me.

Hope the same happy end can be on the other affected units of some people I’m in contact with via the Forum.


Kind Regards,


I just ran into the same issue after I lost and regained power. It took a while but here is what worked for me.

The key for me is that I had previously assigned a static IP address. I went back into my network settings and chose the same IP address using General-Network-wi-fi-mynetworkname-IP address.

When I returned to the main screen, all my missing icons were restored.

I don’t know if it works for everyone but I hope it helps.