Option to disable background updates on macOS

Hello everyone,

While it’s very useful to have apps that syncs in the background using iCloud, I find it ecologically disastrous when my library is on a NAS and Infuse wakes it all day long. My hard drives never goes to sleep.

Could it be possible to have an option for disabling background library updates? I would love that my Apple TV / MacBook Pro / iPhone refreshes only when Infuse is launched - while still syncing settings and libraries using iCloud for the other devices and efficiency.

But stopping network activity when the app is not open, as an option, and not using the OS restriction which cuts EVERYTHING.

Thank you very much.


Have you tried turning off background app refresh in the device settings?

Edit to add: You can turn it off just for Infuse if you want.

Did you see that sentence :wink:

sure did

It’s gonna be a looooong topic :wink:

I’m not asking for support here. I already did, I already had that same answer, and it’s not good enough, not as good quality as Infuse is.

1 - We don’t have to rely on the OS to forbid something that could/should be an option in the app itself
2 - When using that setting, every background tasks is forbidden, including iCloud
3 - I specifically said that we should have the option to maintain iCloud sync, for efficiency purposes, so when an iPhone connects after an Apple TV, it knows the previous changes.

Maybe my first message wasn’t detailled enough.

You can disable background updates on an app-by-app basis in Settings > General > Background App Refresh > Infuse.

1 Like

Hey James,
Yeah, you already suggested that, but as mentioned above, could it be possible to have an option for that in the App itself ?
We shouldn’t rely on the system to block an entire app (including iCloud syncing) but only the library updates for energy purposes.
I feel like I’ve said that already :wink: Please try to understand what I’m asking here.

Sometimes we are left wondering whether Infuse actually have a test bed of an ATV and NAS let alone whether any of the beta testers have more than 5 movies on their systems ? :joy: loool - good luck with this one.

Ps - “ I” understood you perfectly first time …… not sure why others seem to have difficulties with grasping your very easy to understand (and one that is long standing now) issue. When infuse used to “lock” posters in cache it was hardly noticeable but now it appears that has changed and now daily/weekly changes of movie posters by the 14 year old dimwits contributing to TMDB are causing complete havoc …… you get used to recognising your movie poster to find the movie and then suddenly it changes and you visually lose track of it - really daft. Complete waste of resources within the App - yes you can “force” your own movie poster but Infuse STILL checks it and goes to replace it before the custom one over-rides it …. The same is also happening with TV Season Folder Posters as well - it’s a real pain (and rarely happened with TheTvDB :frowning:

To add to this, I would also like a way to stop background processes.

Especially on a Mac, you can’t turn off background refreshes (there is no Settings > General > Background App Refresh > Infuse).

That means as long as Infuse is installed, it initiates outgoing network connections that don’t even stop when disabling Sync > iCloud Sync.

For instance, I didn’t open Infuse in the last 3 days, yet its last outgoing network connection was established 21 minutes ago.

So anyone who installs it on a Mac will have hourly background network traffic even when the app is not running. This is certainly not ideal, especially on laptops with limited battery. The only way to stop it is to uninstall.

Thanks guys. I was feeling alone (and crazy) here…

There is a case for adding a setting on macOS since there is no system-wide setting to disable this. I’ve updated the thread title to reflect this.

Adding a second setting (aside from the global one) on iOS/AppleTV could lead to confusion, so this is probably something we won’t be doing.

1 Like

You can kill Infuse in mission control for iOS, or quit the app on macOS.

This doesn’t make a difference.

It’s an issue that came up during the beta already, but in short, even if Infuse is not running on a Mac (no processes in Activity Monitor etc.) it still initiates network connections in the background regularly, which you can’t disable. This was confirmed by James.

The current thread is based on that very problem because quitting the app on a Mac does not stop the outgoing network traffic. Only a complete deinstallation does.


Sorry, my bad. That’s messed up.

P.S. now I’m thinking about getting Little Snitch again myself.

1 Like

This is seriously annoying - NAS is being woken several times an hour from the MacOS Infuse app (which isn’t even running). I’m deleting the macOS app until this is sorted.

1 Like

Hi Folks,

I’m following back on this previous (and now closed) topic: Outgoing network connections - #32 by james
@james provided an answer acknowledging that thanks to macOS, the app could run a bit of background activity. Same when I asked about this in October 2021 on Twitter.

But knowing it can be done does not excuse the fact it’s made mandatory. So it’s still wrong to me:
“If the app is quit, no check should be done whatsoever. Or at least, an option should be provided. By the way those checks seems to trigger on screensleep. What’s the daemon name responsible of this so I can kill it?”

I got as answer that “Apple doesn’t currently provide an option to disable this (like they do on iOS/tvOS) but I can pass along your feedback and see what we can do.”

Then I asked: “Wait, could you clarify even technically? How can Apple be pointed at for processes (scanning libraries for media updates) your app only is responsible of? Why on earth do you run processes if I decided to quit the app. Can’t you name me those daemons that seat somewhere?”

Sadly this question was left unanswered, I would love to get this explained.
If I restart my computer, I won’t be bothered until I run Infuse. Then even quit, it will always try to make it’s connexions until another restart. There is necessary some kind of daemon running thus an option can obviously be provided to prevent this.

Thanks a lot in advance for your time and explanations.