Opensubtitles is not working now

That’s it. is not working now. The app seems unable to connect to the site. Worked well before…

It looks like OpenSubtitles has been experiencing some downtime over the past week.

You can keep an eye on the current status here.

Please try again soon.


I am under the impression that using opensubtitles reqires a log in. At least when using this under KODI I am reqired to provide my opensubtitles log in credentials. So far I have not found where to put this in infuse, and as of this, I assume opensubtiles can not work with infuse???

Don’t assume. You know how that worn out saying goes… :wink:

First, I am by NO means an expert on how Infuse handles things but from what I’ve been able to glean from reading, the reason you don’t have to enter an ID and password for opensubtitles is that Infuse uses a closedsource opensubtitles API written into infuse that handles the necessary handshakes based on info assigned to Firecore for infuse. As mentioned above and in several other threads, opensubtitles has been going through some server upgrades and that in itself could cause errors in ID the way it was explained to me. Give it some time for the newly induced bugs to get ironed out and hopefully it will be back in shape soon.

Yes, you are absolutely right. My bad. Thanks ?

Still not working… anyone trying to fix this at all? Why not use subscene or bsplayer? They don’t need login… it would be much easier to just link more subtitles providers onto infuse than to ignore our requests for a fix. This will put me off from using infuse and I’ll go back to kodi, especially now that it’s possible to use kodi on the Apple TV 4. I’d really appreciate if you guys couid fix this issue that’s been ongoing since last year!!! To advertise that infuse works with open subtitles is misleading advertising and that should not happen either.

Also not working over here! Not on my iPad nor on my AppleTV.

What’s the fix?

As per the post from james above it appears that the problem lies with open subtitles. If you check the link james provided it appears that they’ve have issues for a week or more so most likely it’s not infuse but open subtitle. Keep an eye on the site status and hopefully they’ll get the problems ironed out soon.

On a related note, OpenSubtitles has announced this week they are slowly phasing in rate limits for the API, which will effectively block a number of abusive apps which have caused a lot of downtime recently. These new rate limits are still very generous, so the integration in Infuse should see no change (aside from better uptime and faster downloads of course). :wink:

3 posts were split to a new topic: Unable to connect to OpenSubtitles

2 posts were merged into an existing topic: Unable to connect to OpenSubtitles