Open subtitles doesn’t work

In the last two days every time I tried to download the subtitles from I get a error message.
Is something wrong with this page API?

OpenSubtitles has been experiencing some downtime as of late. We are working with them to improve reliability and plan to have these changes available in a future version of Infuse.

For now, you can keep an eye on OpenSubtitles’ uptime here.

it is again not working again and the page you gave us is not working too.

I just checked and the stat page appears to be working.

The subtitle source api site seems to still be having issue though.

Hi. The stats page now works but it is not accurate. Right now doesn’t work properly and the page doesn’t show it.
Seriously this functionality is basic for most of us. For a ome of us even more important than the sound and it seems that it is more important 4K or pass through than this.

You have to remember that the status is checked once every 5 minutes so it the server happens to be having issues but only sporadically, it may be up for the few seconds the check is done but it could be down the rest of the 5 minute time frame. I’m not saying it’s only up for the test but the timing could still show as up even though the server is having issues.

Also the response time can have a lot to do with it, your request through the API may be timing out waiting for a response from the server even though if it waited longer it may get the data. The difference between a tenth of a second to get a response and a half second (to over 2 full seconds like recently) can seem like an eternity when you’re waiting for a response.

I know it gets old running into issues and I’m not trying to make excuses, I’m just trying to clarify what the stats can show. I know that Firecore has said they are working on the problems with subtitles so I just try multiple times if I need them and they always seem to get through after multiple attempts over time.

Yes. You are probably right.

Why don’t they just update the app with a fix for this right now instead of waiting for the big 5.9 release?

It’s been going on for a while and is a real PITA, I just tried 30 times to get a subtitle.

As James said, the fix is in progress so it’s on their radar. I don’t think it’s part of the 5.9 update though, the list of improvements doesn’t show it for 5.9, just in process.

My understanding from what James has said, the fix requires both improvements on the opensubtitles site as well as Infuse.

From things James has previously said on other threads about this issue, I believe that opensubtitles are working on changes to the interface used by programs to access the service and only when they have done that work can Firecore make changes to Infuse to use the new interfaces. So Firecore are dependent on the work by opensubtitles being completed.

When can we expect opensubtitles download to work again?

Just DL’ed 3 different episodes without a hitch. Last night it took a couple of tries for a movie but it finally came through. Firecore has it on their radar so hopfully we’ll have better luck soon.

Well, i hope this get fixed soon, because i still cant download subtiles no matter how many times i try. Just an error that i need to check my connection and try again later.

Will the opensubtitles issues get fixed in 5.9.1?

It’s not listed in the 5.9.1 changes but it is listed in the “In progress…” section.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.