Oops, it look your apple tv is not accessible. or the connection was blocked by your Firewall

My ATV 2 has been Jailbreaking. My home sharing and Air Play is working between my PC and ATV2. But it is failed installation ATV Flash black with the message " Oops, it look your apple tv is not accessible. or the connection was blocked by your Firewall". I try to turn off the Firewall on my computer and my router, but it still not solve the problem. Do you have any suggestions? thanks.

I have the same problem.

Apple TV software is 5.1(5201) on ATV2

I’ve tried with the Apple TV over wireless and cabled ethernet.

I need a response to get this working.


I have the same problem as well… Can we have some help please ?

Simple restart apple tv if that did not work Restart your modem/router and let it build the homenetwork again. 



I too have the same problem, I restarted the ATV, and also reset the modem/router. Nothing…

please can we get some suggestions? thanks


Im having the same issue mentioned.  I tried everything, no luck…

Yeah having same problem money down the drain i think


Newbie to this, and bought aTV Flash yesterday. I had the same problem as posted above. I had already Jailbroken my aTV successfully using seasonpass and enjoy XBMC but thought aTV Flash would add extra features and make updating things easier.

Having struggled install aTV Flash onto my aTV my solution in the end was to restore the aTV back to a non-jailbroken state, check it worked then re-jailbreak it using seasonpass. This restored the aTV to a virgin JB state and allowed me to connect to it with the installer program.

aTV Flash is now up and running and I’ve reinstalled XBMC without a hitch. 

Hope this helps.

You have to reset the ATV2 and clean all Jailbraks. Now start over a gain.

I hope it will help to solve the problem.


Would you be kind enough to elaborate on how to “clean all Jailbraks. Now start over a gain.” Thank you


What I think he meant, and what I did to make aTV Flash install & work was to restore my apple TV back to a non-jail broken state by connecting it to iTunes on the PC and using the restore option.

Once its back to its normal apple self then Jailbreak it again. I could then install aTV Flash to it without getting the message above. Since then its worked fine - I’ve resinstalled XBMC and also Last.fm without a problem.

Terrific Jonathan. Thanks so much for the prompt reply. Much appreciated!


It’s all well and good to say you have to restore then re-jailbreak the ATV.  However, after I jailbroke the ATV a few weeks ago, I wanted to go back in via SSH but couldn’t because the password had been automatically changed.  Apparently there was some sort of virus.  Anyway, if I restore the ATV now, I probably won’t be able to jailbreak it again because I don’t know the new password.  I want my money back.

Sounds bad. When I JB’d the aTV password reverted back to “alpine” which is the default password. You have to use “root” as the username too sometimes.

Apologies if you knew this already and tried it. Not intending to teach anyone how to suck eggs, just trying to be helpful.

I have 2 appleTV’s, one of then has this problem :confused:

So I tried SSH to it, but couldn’t…

I tried to do a update to all in NitoTV, but if failed, that I couldn’t lock administrator folder (or something).

Unplugged to restarted the appleTV, did a update all in NitoTV again, didn’t find any updates tho.

Tried SSH, still no connectionen, so unplugged the appleTV again.

Then it wasn’t jailbroken anymore?!? :confused:


ReJailbroke it, and now it work with aTV Flash :slight_smile:

So something in the appleTV’s SSH-thingy must have been broken… :frowning: