Only one title insists on using embedded MKV artwork

Infuse 7.3.2 on AppleTV 15.2 -I have had “Embedded Metadata”

I have about 300 movies and Tv shows and I’m happy to report that every one of them is showing the correct Metadata and cover art, etc just as it should. Really pleased, and haven’t had to manually do anything.

Except one single file - “Ferris Buellers Day Off.mkv”

Infuse correctly picked the right metadata, all the details are right and the artwork shown after I pick the movie from the “Recently Added Movies” list is fine.

However, the cover art in the Recently Added list is wrong. It is showing a thumbnail from what appears to some embedded (within the mkv file) data. “mkvking dot com” (don’t judge).

I cannot figure out how to override this. I’ve tried changing the choices for metadata and that doesn’t do anything.

Options? Thanks in advance

Go to settings and turn off Embedded Metadata.

Then do an edit metadata and re-select the correct choice.

I tried that.

Force closed the app and reopened, Still see the wrong artwork. Do I need do anything for it to refresh?

There doesn’t happen to be a image file in a folder with it?

Yup, after you turn off Embedded Metadata you need to do this

And like munpip214 said, make sure ya don’t have an image file in that folder too.

No, just the .mkv file. No image files used anywhere.

It sounds like this video has an embedded image that isn’t great.

The easiest solution may be to grab one of the posters from TMDB, name it ‘Ferris Buellers Day Off.jpg’ and place it next to the video file.

Following up for everyone:

So, got a .mkv file that had embedded cover art.

I turned off the option in Infuse to use Embedded data, no change.

I tried selecting different metadata, everything changed except the cover art.

I used a tool to change the cover art stored in the .mkv - no change.

I replaced the cover art inside the .mkv - no change. Selected different metadata, went back, still no change.

In all cases, I force quit Infuse and refresh in between. I did not clear cache.

Finally I placed the cover art .jpg into the same folder with same name as .mkv and after restart it worked.

It seems like once Infuse sees artwork inside a file it sticks with that one no matter what - only unless a separate cover art file is provided.

Not sure if that’s a bug but just thought I’d share.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.