Only Infuse can't play movies on DROPBOX

I am currently migrating from Google Drive to Dropbox. And I’m having trouble playing videos on infuse from dropbox. I didn’t really watch anything and now I get a playback error. Which can’t be because dropbox quotas are unused and there are over a billion API calls a month available.

What would we have?
Infuse doesn’t work well with dropbox.
Other apps, such as nPlayer, play files without problems, while infuse gives an error on all devices about not being able to play a video file.

Will this problem be fixed in future updates?


Who has encountered problems with dropbox?

According to your logs, it looks like Dropbox is sending back a 409 error.

According to Dropbox, this is an endpoint-specific error when can happen sometimes when files are moved or changed.

409 - Conflict (Endpoint Specific Error)

Endpoint specific errors can have a variety of different causes - refer to the specific endpoint’s documentation to see error cases and how to handle them.

One of the more common causes for many of these categories of errors is path_not_found. Remember - users may move and delete content, or change the permissions of shared folder at any time through the Dropbox UI - so be sure to test against this behavior.

I understand, thank you very much for the clarification. At this point, it’s been over 24 hours since the error and infuse can’t access dropbox. Do I need to contact dropbox?

Why do other apps with API access have no problem accessing files and infuse has an error?

Thank you.

Can you try removing the Dropbox connection from Infuse and re-authenticating?

This generally isn’t needed, but it may help.

I try that, but it didn’t work. Today it worked. At the time I started getting the error, I was copying data to dropbox, but there were no API calls on the infuse side, nor was there any activity in the log.

Any ideas on how to prevent this error in the future?


Unfortunately it happened again. I didn’t even open any movies, just tested the access speed, but when I wanted to watch a movie, I got an error right away.
Nothing works, infuse can’t access dropbox just flat out.

Nothing is working.

Please figure out the dropbox API.


I want to point out that infuse has not had access to dropbox for over 30 hours.

Also, I did not write, I have a business subscription.


I also noticed that infuse, after each start of the application, re-downloads the details Dropbox.


One of the reasons for a Dropbox 409 error is “restricted_content”, which means that file is restricted due to a copyright claim. Dropbox scans your files and compares their hashes to a list of files with copyright claims, so make sure any files in your Dropbox aren’t downloaded from any media sharing services (or that they don’t have their original hash).

1 Like

No, I copied it in the usual way through the official website.

If that were the case, I wouldn’t be able to run content through other third-party applications, and here the problem is only with infuse and with all files, even with my personal video files.

You didn’t mention how you setup Infuse to Dropbox. I took a look at the Infuse user’s guide and saw this:

Streaming is available on iOS, Apple TV, and Mac however connections to cloud services can only be made on iOS and Mac. Once a connection has been made, this will sync to other devices via iCloud.

Did you setup the connection via iOS or Mac, and migrate it to tvOS via iCloud Sync? Which device(s) aren’t streaming your personal content from Dropbox?

I also want to say that infuse 6 pro also can’t access my dropbox.

Yes, I set up dropbox on my Mac and synced with all devices. My dropbox does not work on any device

I haven’t used (or paid for)my Dropbox for ages, yet they never shut it down…so I thought I would test it out to help troubleshoot.

Firstly I had real issues connecting back and Infuse on iOS actually crashed several times whilst doing my 3rd party auth. I got the connection successful eventually though.

I only added my 4K HDR and or DV test movie section that I still have on there.

There’s about 30 such movies and they took a long time to scan in (it may have always been this way compared to connecting to Google Drive).

One confirmed everything had scanned in and once the tech specs of the files (Dynamic Range, resolution and audio details) were showing on the preplay screen, I have played Dunkirk, GOTG 1, Godzilla vs. Kong for 10-15 minutes each and am currently watching Mulan. All loaded pretty instantly.

To add this is on at Apple TV 2023.


It’s a totally different story on iOS.
Everything says failed to play within a millisecond of even trying to play it. Whilst the files on Google Drive play instantly.

I should also add I’m running the latest TestFlight on both devices.

1 Like

Thank you for your message. I have Apple TV 2023, but she don’t play with my dropbox movies.

You have business subscribe dropbox?

See my latest edit for iOS (nothing plays)

As mentioned I have no subscription at all. They never deleted the files after I stopped using Dropbox well over a year ago.Sorry I can’t help more.

It’s getting later here but in the morning I will test out Dropbox with my iPad Air for you.


One more update on this.
As I mentioned earlier I was watching Mulan throughout on the Apple TV. I stopped it with 10 minutes to go and when I tried to restart it it failed, as did every other movie on the Apple TV via Dropbox.

They must have finally noticed the gap in your bill.

1 Like

I think there is something going on with DropBox.
I actually just got something to play via Infuse on iOS and then tried Mulan again on tvOS and that suddenly started working again too.

1 Like