Only an "Empty Folder" message on my Airport Time Capsule

I just downloaded Infuse Pro, plopping down my $10 site unseen. I tried to connect to my Airport Time Capsule, which shows as an available share, with a “Guest” user name and using the Disk password. But then when I try to add favorite folders it just tells me “Empty Folder. Move along, nothing to see here.”

FWIW, I was able to connect to my MacBook following instructions in another post and can play videos that way. I just can’t connect to my Time Capsule, which is where I have most of my content stored.

Frustrating. Help?

Followed year old advice for the iOS app (from here http://firecore.com/forum/topic/12552) instead of following the advice in the connection guide that’s been posted in the support guides (http://support.firecore.com/hc/en-us/articles/215090977-Streaming-From-Other-Devices), and it worked.

Log in as admin instead of guest.

@wallyg: I use Air Port TC with an external HDD and it works fine - no problems!

Dude, you don’t even know … thank you! I have been looking all over the place to figure out what was wrong and this totally worked. I’m using the newest Airport Extreme and tweaked all kinds of settings trying to get the disk to “just work” like it seemed to for everyone else.

Thanks for posting!!

No problem…Now if someone could explain why half my videos play with disrupted loud static only audio…or just give me an error message…I’ll very grateful.

The same for me. I use username “admin” or “guest” (using the Disk password) but when i try to change metadata then ariive the error message “Empty Folder. Move along, nothing to see here”. I must close and relunch the application to see again the movie list.