Old 3.4.2 aTV Flash

Hi,
i have an older version of aTV Flash and i’m not able to create a new Pachstick. I switched harddrive in my ATV and i would like to use the aTV Flash now.

It says i have 1. No internet connection or 2. Using an old version.
Since i have an working internet connection it must be an old version.

My file is called aTV Flash 3.4.2.dmg for my MacBook. How can i upgrade this file?
Thanks!!

If you bought the flash stick then you can go to the main aTV Flash website > My Account > Log In > Click View under Past Orders > Look at the bottom of the page for the link. Hope that helps you.