Now another atv2 jb issue. Help please

Now another of the jailbreaks has gone wrong. It was the 5.1.1 done without issue. All seemed fine and got xbmc installed and worked for about a week. Then came in and remote would not move around. So I did a pull power and reboot. Comes up fine but remote does not move around the icons. I checked the remote on another and it works fine. The System icon still shows the firecore, but can’t mover around. Tried another remote and still nothing. Do I have to jb again. This is the second time I have had a jb mess up and have to go through it all again. Since I can’t seem to get Tiny to show my units, I keep having to go with the latest but last time I was dead until they did the new jb. I worry that at some point apple will make it not breakable and mine will screw up again and be stuck since I can’t get tiny to get my blobs. Anyone help please?

Hold the menu and rewind (hold left on the center button) on the Apple remote for about 5 seconds. You will see a remote icon on the top left of your tv screen showing the remote “unpairing”