Nothing shows up under TV Shows in Sapphire Media

I’ve just installed the latest aTV flash (4.1.5) on Apple TV 3.0.2 - a number of persistent problems:

1 - Very few of my tv shows are recognised as tv shows when running “Import all Data” in Sapphire Media (I’ve paid particular attention to naming the shows correctly and making sure they are featured in tvrage.)
2 - Even the tv shows which are recognised and marked as tv shows, do not show up under ‘TV Shows’ - this is very frustrating! Movies seem to work fine. I’ve even re-installed my Apple TV, as well as aTV Flash, but no luck.
3 - Occasionally "Import all Data’ just seems to hang.
4 - I’ve tried to update ‘Scrapers’, but that seems to run for hours/freezes.
5 - I could also mention that the initial download of aTV Flash after I’ve bought it, couldn’t download the Apple TV 3.0.2 update file. It started, but stopped every time after a few minutes - tried it a million times, to no avail. (Was done on an iMac computer, running latest Safari + Snow Leopard). I eventually had to resort to downloading it from an external source http://mesu.apple.com/data/OS/061-7495.20100210.TAVfr/2Z694-6013-013.dmg
Would’ve been nice in the instructions if this was mentioned, as it took me quite some time to figure out and eventually found it in a forum, posted by Softpedia.

Is the team at aTV Flash aware of these problems and are they working on bug fixes? Will be good to know, as I’m slowly starting to loose faith in the overall stability of this program, even though it’s a godsend to be able to play other movie formats from an external HD through your USB port.

Will be grateful if the aTV Flash team could provide some detailed solutions to above problems.

I am having the same problem as well. I have an external USB drive connected (as a secondary drive) filled with movies and tv shows. Under Sapphire, my TV Shows do not show up even though for a few of them it did recognize and asked me to select the appropriate name of the show (ex. Mad Men). So, I though everything was going to be fine after it fetched metadata, but now they do not show up at all. Also, I’m unable to actually see the drive directory with all of the raw files (not attached to metadata), unlike previous versions of ATVFlash with Sapphire/Nito. I’m not sure what’s going on. Now I can’t actually watch the tv shows that are on my drive because I can’t find the drive directory. Anyone else experiencing this?

@emoney1 You may try the fix outlined here: http://forum.atvflash.com/viewtopic.php?f=6&t=3358&start=10#p14101

@Mandrid Just responded to your PM.

I’m afraid that hasn’t solved the issue for me - still nothing under TV shows.

Any advice Max? Should there be a directory, named 'TV Shows" I hope you guys are giving this high priority, because a lot of people seem to complain about this issue - first of all the download issue as mentioned and then the problem with TV Shows.

Can you give an example of one (or more) of the tv show filenames you are having trouble importing. We can try and replicate the issue here.

Hi Max

None of the tv shows are importing (and I have a lot!). File names eg. Fringe.S01E01.avi

I have a Seagate 1.5 TB external drive and the shows are listed under the directory ‘TV Shows’, followed by a directory for the show, like ‘Fringe’, followed by the above file name for the show.
The external drive is formatted in MSDos.

I hope you have more luck than me!

Same problem here. Have tried the fix as suggested but whereas Sapphire was before trying to take my TV show and compare it to IMDB, now it won’t recognize it at all.

I ripped a TV series from DVD so that I have the disc menus to navigate through the episodes (as opposed to single files for each episode). Does this matter? I would really like to catalogue the TV show using Sapphire and all of the episodes do appear on tvrage.com.

I’ve managed to do a proper download of aTV Flash + Apple TV 3.0.2 update file (this time I’ve disabled any Network Monitoring programs, which seemed to do the trick).
I then did a clean re-install of Apple TV, updated it to 3.0.2 and then installed aTV Flash from a flash drive. Somehow the program seems to be a bit more stable, but:

  • still nothing under TV Shows in Sapphire Media Player, even though it recognised some as tv shows during ‘import all data’.
  • ‘import all data’ hangs quite often.
  • ‘update scrapers’ seems to download forever - I eventually had to unplug my Apple TV after hours of trying to update Scrapers.

Any proper solutions from the aTV Flash team yet? I don’t seem to be the only one with such problems. If anyone has similar problems, please let your voices be heard!

Hi. I too cannot seem to get my TV Shows to appear. I have tried the fix with sFTP here:

http://forum.firecore.com/topic/2882?page=1

The TV shows appear in collections fine. And my Tv shows are also listed in RageTV. Any suggestions welcome. Thanks.
 

 Purchased ATV and aTV this week.

Same problems as above. Have tried suggested solutions and reinstalls. Does not work.

Sapphire Media seems to get the data, but fails to attach to the files.

 

Update Scrapers just hangs on the spinning wheel, and you have to pull the plug to escape out.

 

Other than this and a rapid popping noise when I attempted to play a DVD TS folder, loving it!

 I'll just join the club - 1. importing just seems to work fine, but then there the TV shows directory is still empty. 2. scrapers can't be updated (though new folders in "library/app support" are created: Sapphire/scrapers/common)

looking forward to a solution to this frustrating matter...

Hi guys,

I had been following these related posts for a long time and, like you, was suffering with Sapphire not updating the TV shows & Movies lists.

Through other posts in this forum and a bug post [1], I found a fix that worked for me. I'll post it below in hoping that it will also help others.

1. Download this file here and save it to your desktop - 

ozmatrix.com/downloads/tvrage.txt

2. Using your FTP program (eg. Cyberduck, Transmit), upload this "tvrage.txt" file to your AppleTV in the frontrow user home folder.

3. In an SSH terminal session, run these commands at the prompt ... 

(i) sudo mount -uw /

(ii) sudo cp ~/tvrage.txt /System/Library/CoreServices/Finder.app/Contents/Plugins/Sapphire.frappliance/Contents/Resources/Scrapers

(iii) cd /System/Library/CoreServices/Finder.app/Contents/Plugins/Sapphire.frappliance/Contents/Resources/

(iv) sudo chown root:frontrow Scrapers/

(v) cd ~/Library/Application Support/Sapphire/

(vi) rm metaData.sapphireDataV3

(vii) touch metaData.sapphireDataV3

(viii) chmod gou+rw metaData.sapphireDataV3

4. From the Sapphire menu on the AppleTV, choose Sapphire -> Settings -> Fetch TV Data

5. Hopefully all now works.

Regards

Scott

Cairns, Queensland, Australia

 

Reference

[1] http://appletv.nanopi.net/trac/ticket/383#comment:6

I'm having the same problem Sapphire is not showing anything under the TVshow. I tried some of the solutions recommended but I haven't been able to make Sapphire work properly. My problems started after the last update. 

Please. Help. 

I was having the same problem, until I decided to restore my apple TV and re-install the aTV flash, I took me a while to import all my media again but this solve the problem. If you don't find any other solution you may try this, it worked for me.

My Desperate Housewives tv series are dvd video_ts files on 5 dvds they are named DH30EUT1 to DH30EUT5, What should I rename the to get metadata?

Same here tried a few series and they are still not found. Can someone post an example of a show they have had to change the name for sapphire to work. For example my file is called " true blood series 1 disc 3" i have tried TrueBlood.0103.Video.Ts etc but no luck any suggestions? As previously mentioned, does the fact that you rip a full disc have an effect. So for example episodes 1-3 are all in the same video TS folder and you only access them through the DVD menu?

Just want to put my name on the list as well. Sapphire was working fine for me prior to 4.2, but now I don’t see any movies or TV shows. Very frustrating because this was one of the features that convinced me to try ATV Flash.

 Adding another 'ditto' to this thread. I've used the sFTP fix, but with no results.

 For what it's worth, I tried the SSH terminal solution above, but that did not work either. Data is downloaded, but not linked to movie file and movie file is not moved from 'Collections' into 'Movies.'

Same problem here since yesterday. I added new movies on my HD, data is downloaded (But not the screens to select art covers - ?). New movies are not moved to 'Movies'. They stay in 'Collections'