Nothing Shows up in Sapphire Under Movies or TV Shows

Hey Guys,

I’ve been playing with this for hours on end now, reading posts, troubleshooting, deleting files through CyberDuck - the whole 9 yards - and I just can’t get anywhere!

All I want to do is put all my movies onto AppleTV and import them with Sapphire so they have Cover Art. I copied two movies to the ‘Movies’ folder of the AppleTV with CyberDuck (Iron Man and Get Smart). I then go to ‘Media’ on the AppleTV and click on ‘Import All Data’. This process seems to work, it takes about 20 seconds and says that it processed two entries. After this I go to ‘Movies’ and there is nothing there, it just says ‘Scan for New Files’ - which does nothing :twisted: :twisted:

Does anyone have any idea how to get this working?? I’m debating between using an AppleTV or just buying a Mac Mini and running XBMC on it, earlier today I was leaning heavily towards the AppleTV with ATV Flash, but I’ve had zero luck getting what seems to be a very common and basic feature to work.

I tried dropping in the MetaDataV3 file, it is there but doesn’t make a difference. I tried to delete the mounts.plist file from the Nito directory (/Library/Application Support/Nito/…) but there is no file there called ‘mounts.plist’ - could this be part of the problem?

Any and all help and guidance would be greatly appreciated - this is my weekend project but hopefully it doesn’t take all weekend just to test out the AppleTV!!

EDIT: The movies do show up under collections, but just as a file name - they play just fine though.

Thanks,

Mike

Hey Mike,

I was having exactly the same problem as you this weekend. There seems to be a problem and I’m sure an update will be available soon but in the meantime there is a fix.

There is already a thread on this problem:
http://forum.atvflash.com/viewtopic.php?f=6&t=3358

But here’s the comment on how to fix it…it worked a treat for me.

[i]This file may not be automatically creating itself if not already present.

You may try downloading the blank file in the link below and copying it to the Library/Application Support/Sapphire folder via FTP (or /Users/frontrow/Library/Application Support/Sapphire when connected via SFTP) to see if this resolves your issue.

A guide for connecting via FTP can be seen here: http://wiki.atvflash.com/index.php?title=FTP

http://dl.dropbox.com/u/111543/Dev/metaData.sapphireDataV33

We’ll try and replicate the issue here.[/i]

Hope this helps :smiley:

I tried to add that file to fix the issue but it didn’t work for me - it did for you??

Where did you put the file, maybe I put it in the wrong spot??

Thanks,

Mike

Once you’ve added the file, remove Sapphire from the plugins list (uninstall it) then reinstall it again and it should work fine.

Okay, I will give that a shot now.

Pull the plug in between uninstalling and reinstalling?

And do I leave the file name exactly as follows, “metaData.sapphireDataV3”?

Thx,

Mike

Okay I just removed Sapphire - with the metaData.sapphireDataV3 file in the /Library/Application Support/Sapphire folder, restarted finder, installed Sapphire, restarted finder and to still no avail.

I tried clearing the metadata for one movie and then doing import data again and it seemed to update but there is nothing under Movies!!!

Is there a specific way the files need to be named?? I’m going nuts here guys, I’m really hoping I didn’t waste $50!! This seems like a pretty basic and heavily advertised feature…

Anymore ideas on how to get this working??

-Mike

Hey Mike,

Here’s exactly what I did.

I read the entire thread at:
http://forum.atvflash.com/viewtopic.php?f=6&t=3358&start=10

I uninstalled Sapphire and then reinstalled and populated all data…it didn’t work.

I downloaded the blank metadata file and used ftp to add it to Library/Application Support/Sapphire folder

I then uninstalled Sapphire and reinstalled it again.

Then I populated all data and it worked with no problems since.

With regards to your other questions:
No I didn’t pull the plug at anytime
Yes, leave the file name exactly as is.

It seems that everyone who has had this problem have resolved it by following the steps mentioned in the thread above so it should work for you. Maybe before you start the above process unplug your ATV wait a few minutes plug it back in and give it a shot.

Hey,

Followed your steps exactly, still no go. It did re-download all the information for the two tv shows and two movies, but still nothing shows up under either TV Shows or Movies…

Ugh this is so frustrating!

-Mike

Mike

I was having exactly the same problem as you and had followed the steps as above. In the end I ran the apple updater so I had the latest apple tv software and then re-flashed the unit and hey presto it started working. Not much of a solution I know but it worked for me.

Hey,

I too have the exact same problem as you Mike.

I also followed the steps exactly, yet no success. I updated the scrappers as described elsewhere, no success either!
As a last resort, I even did a factory restore, created a new patchstick using the current aTVFlash 4.1.5 tool and flashed it successfully, but still no go !!!
The Import all data process sometimes hangs indefinitely, sometimes it runs through. When it does run through, it asks me to identify my episodes and movies. So, it is in deed able to contact TVRage as well as imdb. For movies, I even get to choose the correct wallpaper. Yet, most of the times the process ends with the message: “Updated 0 Entries.”
Strange enough, all movies DO show up correctly in the Sapphire menu, but TV Shows do NOT! I don’t understand that!
There must be really something wrong with either the current Sapphire or aTVFlash release.

There are tons of people complaining about this problem in multiple threads.
I am so frustrated, could anyone at FirCore please solve this huge problem fast!

For me, the only reason I bought an aTVFlash license in the first place, was to use Sapphire and keep it up to date easily. It’s quite ironic that this whole mess started when I ran the maintenance and Sapphire updates this weekend. The box just got completely useless to me!

I did NOT buy a lifetime license for this!!! Right now, I am not satisfied and will make use of my dissatisfaction clause, if you guys at FireCore can’t get this right!
I am sorry, but I do expect more support for my money.

Adrian

I am running AppleTV firmware 3.0.2, patched with the latest aTVFlash 4.1.5 which includes the current Sapphire release 1.0b8.0.5.1.

It looks like there was a Sapphire scraper update released today. I’d recommend the following.

  1. Update Scrapers through Media --> Settings menu.
  2. Restart AppleTV

This should resolve the TV Show scraper issue.

Hi there

Having the same issue here. Have done everything in this thread so far, including the last post, all to no avail. I can use NitoTV to play my files but its very clunky compared to Sapphire - I miss it! When I click on import all data it stalls at 566/567 with 0 URLS remaining. I then cancel that and try running it again and this time it does go through, says it has updated 6 entries but still has the showing up.

Something is amiss here methinks. Any more ideas?

Thanks

Chris

I have to agree with AdR. I bought this product specifically for Sapphire. I’ve lost count of how many times I’ve reinstalled ATV and/or rescanned my directories.

It’s about time you guys fixed the sapphire issues once and for all, or start offering refunds to dissatisfied customers.

I can’t get Sapphire to work at all since installing 4.15 I get an error something to do with loading common player files.

I cannot watch DVDs in Nito either - it just quits to the finder each time.

I’m really sick of this, particularly since I had it working just how I wanted before this stupid upgrade.

I keep getting an “install failure” with sapphire and the existing version crashes my ATV every time I attempt to scan my directories- sounds like the recent versions are super buggy- please fix!!!

Still the same issue since the update, movies are fine but not TV shows

Can you at least give us an update that you acknowledge the issue & are working on a fix, no communication just frustrates everyone?

We’re looking into a few similar reported issues. In the meantime you may try the following.

  1. Download and re-install aTV Flash 4.1.5 from a USB drive.
  2. Update Scrapers through Media --> Settings menu.
  3. Power cycle AppleTV.

To locate your aTV Flash download link:

  1. Click the My Account link near the top of any page of our site.
  2. Log into your account.
  3. Locate your order in the ‘download links’ section and click ‘view’
  4. The download link will be near the bottom of the page

Max, thanks for the update, hopefully the fix isn’t long away.

Question: I have never ever been able to Update Scrapers as it just spins & says downloading forever, I think this is an issue for a lot of people, do you know why this happens?

It’s most likely a network issue. The update should only take a few seconds. Do you happen to have either the Hotspot Shield or Tunnelblick apps enabled in the Maintenance --> Settings menu?

No I don’t have either of them running, should I?

Oh & BTW bizarrely for no reason at all (as I have just got back from work & tried again) everything just undated itself correctly, very very weird, happy but weird