Not updating library, Scan for Changes unresponsive

Everything seemed to be working fine upon first day of use. Infuse found my cloud drive and files instantly, coverart, metadata, subs all working great…etc,…

Then last night I tried to add some new movies and moved a few files around in the directory structure of the cloud drive. After I returned to the library and found nothing had updated in the library. ie. Movies that were moved still showed in original locations, and new movies not discovered… The “Scan for Changes” button is unresponsive, it only highlights but does nothing upon press; the Movies, TV, Other field on same screen always shows 0. Basically I’m seeing the same library that was discovered after the very first install.

Here are some things I have tried which have NOT fixed the problem::

  • Removed Infuse and re-downloaded (several times)
  • Removed the share and re-favorited folders (several times)
  • Rebooted router, clouddrive, aTV4 (in tandem)

Using latest version of Infuse Pro
Apple TV 4th gen
My primary share: Western Digital My Book Live (UPnP) - 3tb

UPnP shares will need to update/index the content themselves before changes are made available to apps like Infuse. How often this takes place will vary between devices, but it can range from a few minutes to an hour or more.

Does your device support streaming through any other protocols, specifically SMB, FTP/SFTP, or WebDAV? These are all direct access methods, and changes will be immediately available to Infuse.

Ah perfect, thanks. Tried the SMB and it rescanned everything instantly. Yes the Mybook Live appears to support FTP, WebDAV. I’ll look into those ones later… Looks like I need to figure out the port-forwarding on my router for those ones (?). Anyhow thanks again, bigtime. :slight_smile: