Not showing folders and frequently unable to navigate folders

Hi! I use a Time Capsule, SMB by default, I tried changing the name of a folder and the image appeared, but sometimes this does not work

4.1 does not work for me either…

Hard Drive attached to Airport Extreme - was working fine on 4.0 - 2 folders of Movies and I could watch on Apple TV, iPad, iPhone etc. Now all I keep getting is “Sorry, Infuse encountered an error while trying to connect” - on any device - apple Tv, iPad or numerous iPhones.

Please help - great product. Would this be sorted by Pro? Happy to purchase if so…

Hi,

I’m having this “not showing folders” error too

Everything was working fine till this new update.
Now I need to disconnect the apple tv and airport time capsule, then connect airport - > apple tv to start working again. And everything works fine for some time.
How can i downgrade the app, is there any way to do it?

Apple TV 4 9.1.1 (I did not update yet to 9.2).
Regards,
Marco

Hello,

Since the latest update I am also having the same trouble. My favorite folders are showing empty until I delete and re-add my dlna server.

My other devices show the server just fine. I am using universal media server on a Windows machine which worked fine before the update.

Hi,
Same issue since last monday. I’m not sute but I guess it’s been updated.
It was all working fine before.
I have two sources: an OSX shared folder and a Sandisk USB connected to an airport. And I usually stream video to an Apple TV and an iPad

I wish this info may help somehow. Now:
From the iPad I can see video files from both sources.
From the Apple TV I still see the Sandisk files, but get the error trying to open the OSX one.
Deleted/ reintalled the App and still the same

Hi again,

I found a solution. At least for me.
This other post gave me the clue: Unable to reach Nas
I had the Mac plugged (ethernet) and connected to the wifi at the same time. Once the wifi has been disabled, it worked again

Not sure how that applies tbh. My AppleTV 4 is ONLY connected via ethernet, there is no WiFi profile saved. Hard drive plugged into Airport Extreme.

^^^^ How would “Mac plugged (ethernet) and connected to the wifi at the same time” have any effect, it’s a separate device entirely and not being used to view the movies

Anyway, tried it again today and guess what, it had lost all data. So in I go and re"index" everything again (i.e. edit the files it can’t place manually).
Once all done, I settled down for a browse and came across the “empty folder” message again.
Had to exit the app, reboot the AppleTV before Infuse would index the folders again.
Lasted about 2 min before I got the “empty folder” message again…

…and again…

…and again…

…and again…

Every time, infuse will only work again AFTER a reboot of the AppleTV (which DOESN’T happen with multiple others such as VLC, FileBrowser, PLex etc etc).

Imo it’s a fairly broken app - update after update and the devs don’t appear to care to fix it :frowning:

I find that if I change the name of the folder in Infuse I get a connect error. Then if I change it back I can see the movies again…still a pain!!!

Same issue here, old firecore infuse on ATV3 works fine.

I’m using Infuse Pro (V4.3.4) on an Apple TV 4. All my media is on a WD MyCloud Mirror. I cannot get folder art to display either. I’ve tried putting a folder art as a JPG in the folders but it didn’t work. Everything else works great. I hope the next update resolves this.

I’m running a WD MyCloud and I’m having no issues with displaying folder art just make sure the jpg file has the same name as the folder you want it for and that it’s in the same directory as the folder, not IN the folder. They need to be at the same file level.

Example

-My Video files (folder)
<----->-My_Movies (folder)
<---------->-Movie.One.mkv
<---------->-Movie.Two.avi
<----------> -Movie.Three.mov
<----->-My_Movies.jpg

Thanks for this suggestion. I have tried this but it didn’t work.
Here is what I have tried:
1.
-My Video files (folder)
<----->-My_Movies (folder)
<---------->-Movie.One.mkv
<---------->-Movie.Two.avi
<----------> -Movie.Three.mov
<----->-My_Movies.jpg

-My Video files (folder)
<----->-My_Movies (folder)
<---------->-Movie.One.mkv
<---------->-Movie.Two.avi
<----------> -Movie.Three.mov
<---------->-My_Movies.jpg

-My Video files (folder)
<----->-My_Movies (folder)
<---------->-Movie.One.mkv
<---------->-Movie.Two.avi
<----------> -Movie.Three.mov
<---------->-folder.jpg

None of these work.

Are you referring to the “Favorites” folders on the Infuse home screen?

If so, they have to be named “favorite-atv.jpeg” and be placed inside that favorite folder.

Just trying to clarify which folders your having difficulty with. As I said earlier, I’m running a WD MyCloud and so far it’s all working.

Did anyone ever find a solution for this? I have this happening for a long time and it still happens on Infuse 5. I think it has something to do with the apple routers, when a folder has a huge number of files and you try and access it from more than 1 device at a time.

And it happens on the Apple TV and iOS apps.

I’m connected by SMB into my AirPort Extreme with hard drives connected to it.

I am running the latest available version of Infuse 5 on ATV4, and this issue STILL persist one year later. Why has it not yet been resolved? I just now have the exact same behaviour. A very annoying flaw. On PC I am running KODI v.17 Krypton on the exact same library flawlessly. Hopefully James will reply with a follow up.

Got this sorted today. Fine tuning of library structure and file names did wonders. Looks like the scraper of infuse is a lot more sensitive than the on used by KODI, as the GUI looked superb in KODI but awful with infuse, both scraping the exact same library.

I encountered the same issue today when adding a folder.

Running 5/5 on 6 ATV4’s, 3x 3tb WDMyBookLive, several shares, one pointing to one particular folder on the drive, “Series”. Each time I added a folder and a file, it would not show up on the list…adding a folder.jpg file didn’t display. In a year I hadn’t encountered this issue, thought it may be a bug.

After a trial and error, renaming the folder, deleting it and creating a new one, I finally found the issue:

The folder only contained one playable file (.mp4). When I added an additional file to the folder, it showed correctly on the file list, with proper artwork and metadata.

Forgive me if this has been covered before, but a web search led me to this topic in the forum, so I thought I would add a post on at least one “solution” to the problem.

It would be nice if the software would allow for one file for folder/tree customization is the user desired.

Cheers…

New user of Infuse Pro here.

The above “solution” does not work for me. My ATV is connected to a Synology NAS via DLNA, and Infuse is working great in most ways. I was able to customize Favorite folders by selecting artwork through the app menu.

But folder.jpg and folder.png files for folders do not work no matter where I place them. Poster view presents only the stock folder icon. Nothing I found in this thread helps. Will this be fixed?

Per one of James posts “Unfortunately external folder/favorite artwork won’t be available when streaming via UPnP or DLNA.”

Try SMB and see if that helps.

Here is what I did to get the folder images to show.

  1. I have all my media stored on a MyCloud Mirror. I made sure that I was sharing the media via “NFS Access”
  2. In the settings in Infuse, I selected the Share using the IP address of my MyCloud Mirror
  3. all the image files within the folder are called “folder.jpg”

I hope this helps. Like I said it worked for me.