Not fetching metadata from TheMovieDB

Hi, I live in Sweden and the app are in swedish if that make any difference? I’m not getting any metadata on any of my files, some of them has the swedish name and some of them the english name. When i try to refresh metadata I don’t get any suggestions, it’s all blank.

I have the same filenames in XBMC on my ATV2 fetching metadata from TheMovieDB and TheTVDB without any problems.

Here is some of the files that will not get metadata:
A Turtle’s Tale - Sammy’s Adventures (2011).avi
Alla vi barn i Bullerbyn (1986).avi
Bee Movie (2007).avi
Du Är Inte Klok Madicken (1979)-CD1.avi
Du Är Inte Klok Madicken (1979)-CD2.avi
Emil i Lönneberga (1971)-CD1.avi
Emil i Lönneberga (1971)-CD2.avi
Ice Age (2002).avi
Hotel Transylvania (2012)-CD1.avi
Hotel Transylvania (2012)-CD2.avi
Madagascar 3 Europes Most Wanted (2012).avi
Pippi Långstrump På De Sju Haven (1970)-CD1.avi
Pippi Långstrump På De Sju Haven (1970)-CD2.avi
The Lord Of The Rings - The Fellowship Of The Ring (2001).mp4

This movie gets renamed but no metadata:
Madagascar 3 Europes Most Wanted (2012).avi
New name in InFuse:

TV-Shows is fetching metadata, works like a charm, the covers and text looks very nice:
Game of Thrones S03E01 SWESUB HDTV XviD-SD.avi

So it seems like TheTVDB works as it should, but not TheMovieDB.

Any suggestions or ideas?

Sorry for the trouble. This is an issue in the current version of Infuse due to a recent API change at TheMovieDB. In a nutshell, any movies that contain dates in the filenames will not have metadata available.

This is something we’re working hard to fix, and are planning to submit a quick 1.2.4 update to the App Store ASAP.

Ok, I was going nuts since I couldn’t get it to work. Looking forward to the update. InFuse is a really great looking movieplayer, I usually use CineXPlayer, but they have pusched to many functions to it and it’s to many bugs, not so good looking either. InFuse with metadata, airplayer and the possibility to download movies through SMB or AFP is going to be the ultimate player.


Good morning.

If I understand you correctly, this is a problem of Infuse and TheMovieDB.

But I am having the same problem using the media player on my ATV2. I know that “if it ain’t broken don’t fix it” but I thought it might be a good idea to reset all metadatas because I often delete movies once I have seen them. So my intention was to have a clear database. But now most movies don’t have any metadatas at all. It seems like a scene from a movie is shown as a cover and that’s it, no information about actors etc.

Any hint how to fix this problem?

Best regards from Germany.



The change over at TheMovieDB is affecting quite a few apps, including Infuse, aTV Flash (black), and XBMC. Essentially they started requiring the release year to be sent separately, whereas before the title and year could be sent together in a single query. TheMovieDB guys are great, but unfortunately in this case there wasn’t much of a heads up to let us know things were changing.

Updates for both Infuse and aTV Flash (black) are in the works, and will be available soon.

Thanks a lot for your reply. I hope you guys get this solved quickly.

Best regards from Germany.



when do you think will an update be available? I am asking because I find it rather annoying to not have any metadata shown.

So I am thinking of renaming all files which have the year in the filename. But if an update comes out in let’s say one or two weeks I just might want to wait.

Best regards from Germany.



Version 1.2.4 was submitted to the App Store today, and will likely take 4-5 days to be approved.


Here’s what’s new in 1.2.4: 

  • Updated movie search to handle the recent TMDb API change 
  • Improved support for embedded metadata 
  • Videos can now be paused/resumed using headphone controls 
  • Re-enabled access to synced music videos 
  • Minor visual improvements to cover art on iPad
  • A few other minor fixes and performance improvements


That’s good news for those who are using Infuse.

But we are talking about the Media Player on an ATV.



We’re in a bit of a tricky spot at the moment, as we’re working to merge Media Player into the Infuse codebase so new features can be easily pushed to both platforms. The downside to this is that it takes a bit of extra time to push fixes on the Apple TV side (at least for now while the merge is in process), but we are planning to have the same fix available on the Apple TV side ASAP.

Looking forward to the InFuse update, thanks!

If you want see coverart in mediaplayer (ATV2), you can copy the coverart in the same folder as the movie. You have to rename the coverart to the name of the movie. Problem solved.

Yes, this solves the problem. But this is an unnecessary step and worked without it before TMDB changed the requirements.

The way I use the mediaplyer is that I have one folder on my NAS. Whenever I copy a movie ( mkv ) to this folder atv recognises it and automatically downloads the relevant metadata.

So I don’t need to download any coverarts nor do I need to have separate folders for each movie.

And I’d like to see that working again :frowning:

Regards from Germany.



I work the same way. This solveer the problem until Firecore solved their problem with Themovedb.

Would this be the same issue? I have added new movies to my NAS/media server and they are not showing up at all in the media library? I have almost 1000 movies on my server, but noticed that only about half of them show up when I brows through my titles? Why is that?



that’s exactly what we are talking about.

But I honestly doubt that this issue will be fixed soon, if it will be fixed at all.

I installed Plex server on my NAS and Plex client on my Atv -> no isues with the metadata

I also installed XBMC on my Atv to see if I had any problems. Same here -> alll metadata corretcly shown


On the other hand I must admit that I don’t know if Plex&XBMC use a differnent online-database to fetch all the information.





Do we have any news on when an update for Flash Black will be avaliable to fix this issue?

I like many others have a NAS drive with a single movie folder and all my movies dropped in there. Some of my movie files have a Year on them some don’t. I even added the year to some of them to ensure the correct Metadata was retrieved after a re-install / clearing of the cached data. I was having problems where newer movies wern’t being added so I removed all the cached metadata and re-scanned the whole share. Now its even worse with about 50% of my movies now being in the “Others” section.

I see an update for the Infuse app was out 3 days ago, which is all well and good, but what about your loyal customer base on ATV Flash Black? Is there any update as to when we might see an update to fix this? I really don’t want to have to go rename all my movies, as mentioned some have the year on them intentionally to ensure the correct metadata is retrieved.


We’re working hard to get this fix implemented on the Apple TV side, and hope to have it out this week.

Hang in there.

Thats good to know James, thanks for the response.