Not connected to a server - after wake

Latest version solved next part. It seams, that while I’am in seson in TV series, error is gone. But, when I’am at list of seasons, error is still present.

It seems, that now is problem in root of favorite folder and 1 subfolder. And new problem is, that it is not only while I am in that folder and going back from other app, or while I turning on aTV.

New update, not solved. “Thanks” again, dear dev.

Did you consider trying his suggestion?
Seems pretty simple.

To avoid this, you can simply navigate back to the Infuse home screen before exiting the app

Sorry, but this was a stupid suggestion. Every time I want to turn sleep aTV or switch to another app do this suggestion. And when I go to sleep and then aTV sleep after time automaticaly, I can’t do it because… I’m sleeping.

It’s worse now than before the latest update. The developer hasn’t done anything for years, and if something changes, it seems like it’s just a coder’s next mistake. And support ignoring this theme.

Yeah, I’m full of them. Thanks for noticing.

So, I’ve tested this scenario: If I put my AppleTV to sleep manually, it turns off also my TV and soundbar system. If I then turn my TV back on with my Apple TV remote, the Apple TV always returns to what I was doing — from watching a video, to browsing any folder.

If I use the TV remote to turn off everything, I also return to wherever I was. Can’t replicate your issue.

My AppleTV is set to “Sleep After: Never
And “Turn On Your TV with Your Remote: On”.

In any case,
The solution you desire is likely coming in tvOS 17 — the Apple TV will be getting a sleep timer.


You can use the sleep timer on your AppleTV, and everything will shut down smoothly. Turning everything back on will return you right to wherever you were when your AppleTV turned everything off.

1 Like

Try this.

  1. Open Infuse
  2. Browse TV Series and place cursor (focus) on any season. Not open season, only stay on it.
  3. With mainscreen button switch to Apple TV settings and browse few minutes settings, opening menus, submenus, back or so.
  4. With homescreen button switch to Infuse.

Next you can try to same state in Infuse, switch to youtube, play video. Turn off/sleep aTV. After some time (morning? :slight_smile: ) turn on aTV and switch from Youtube to Infuse with homescreen button.

And same thing happend occasionaly without this, simply same place in Infuse, aTV turning off/sleep and then after few hours I turn on aTV. It is not 100%, but many times.

This not happend (now, before years was same problem here too), while you have paused video in Infuse, this hold connenction to server. After latest update this not happend while you have focus on video (file), that is not played too.

Here is my todays morning video, I have dev beta 17 too: Firecore Infuse - Not connected to a server error - 4 years later - YouTube

New updade, still not fixed.

New updade, still not fixed.

New update, still not fixed. Stpdevs :frowning:

New update, still not fixed. 1565 days in “investigation” without fixing.

New update, still not fixed.

Still same, simply switch to Youtube.app, then back to Infuse and…if focus is not on file, still error with connection. 4 years and still not solved.

I mean, simple solutions have been provided; you just don’t like them.

Also, it’s been 4 years since you’ve brought this up, and after all this time, the first post only has one like — and no one else experiencing the issue has even commented in this thread since February of 2020 — both clearly indicating no one else seems to be having a problem.

1 Like

And still not solved after latest update. What you wrote is not solution for solving problem. It is like buying car and in descriton you see, that car can turning left and right. But, to right you can’t turning, because of locked steering wheel. Solution is to solve that locked steering wheel and not to write, that you can ride on streets, on which you hit destination, if you will steering only to left.

A still not solved.

Still same, not solved.

lol. This thread. Props for being persistent though…

Anyways, as the dev posted, years ago, this behavior is a limitation of tvOS. ie, it’s an apple thing yo.
I have this happen from time to time too, always have. Not just in Infuse, but in the Plex app, and Channels DVR. App is suspended in the background, or the ATV goes to sleep, it is normal.
Even have it happen on my Nvidia Shield sometimes (Android TV) with some apps, when it goes to sleep.

It is normal, deal with it. Or use something else.

2 Likes

You don’t have right, because in time it changing, problem was moved from one place to other.

And, today’s update … not solved problems.