Not connected to a server - after wake


sometimes, when I turn on aTV, while Infuse was turned on before aTV sleep, I see “Not connected to a server”. But, NAS server is olways ON, ahter I press menu, I see arts.

Where is problem?


1 Like

No one have same problem? Latest update is worse, than previous and problem U have in 90% of aTV power on. Now I have Synology NAS, but same problems was with HDD connected to Turris Omnia router.

Yes, I see this a lot. It doesn’t appear to try and refresh the connection before displaying the error.

1 Like

You said “but same problems was with HDD connected to Turris Omnia router.” I’m guessing that you no longer have this set up. Did you delete that share for the Turris from Infuse completely?

Also, are you disconnecting the power from the ATV after putting it to sleep?

Do you leave the app active and in the foreground when the Apple TV goes to sleep? If so try backing out to the main Apple home screen when your done watching.

NC Bullseye: Yes, complete delete, other router, complete new settings. It seems, that problem is not my setup.
JarvisMeier: I never closing Infuse, each time, when aTV going to sleep, Infuse is in foreground and movie/TV series ended play, or I manualy turn sleep mode while Infuse palying movie/TV series.

Try putting it in the background and see if it still happens. My thought is Apple terminates the connection to the share and infuse can’t reconnect in time.

This can happen if you are browsing a folder directly, and the app goes into the background or the Apple TV goes to sleep. In essence, the network connection in Infuse will be broken when the app is closed (tvOS limitation).

To avoid this, you can simply navigate back to the Infuse home screen before exiting the app or browse your files using the Library instead of folders.

Thanks, but it is not solution for me :frowning: 99% of aTV sleeping is when noone looking at TV (night, sleep before movie/TV series end). And Library is not so comfortable. I mean, that this was not before problem.

Agreed. I think we understand why it is happening, but do not like the solution.
I would hope that the app would be able to reconnect when it is resumed, instead of just erroring. Or if it can’t, why can’t the app quit back to the home screen if it detects the error? It would be a more elegant approach

Agree. And maybe add function, that remembering, in which folder and on which file I was before Infuse lost connection. Same problem is, when TV OS kill Infuse, or after restart.

New update and this few years error not solved.

And next update and still not solved. Problem is not only after aTV resume, but sometimes, while I use other app and go back to infuse, it is same problem.

While it may not be what you want, try setting the TV to NOT go to sleep.

Thanks, but, as you wrote, it is not solution, especially, if I need to turn off TV (I use CEC) after aTV going to sleep :frowning: And if aTV kill Infuse because of other app, it can’t be solution.

Maybe problem is only while Infuse is not playing video. It seems, that while I have paused video, it working like network function “keep alive”. But cant tell it 100%.

Turn off sleep and video screensavers on your ATV. They seem to kick Infuse out of memory. I no longer have ‘indexing failed’ problem.

1 Like

It is not solution, because sleep and screensaver is for me “must have”. It turn off TV too after I sleep while TV is ON.

And still not solved. I have now 4K 2022 with LAN a sometimes see not connected.

New version 7.5 released and…? Still same. Thanks for support, dear developer.