Not all the files transfer from ATV to External HD Storage

I successfully switched my ATV from internal to external storage and it appears that all of the files have transferred when I view content from my ATV. However, when I connect my external storage to my computer, it doesn’t appear that all of the files are there. What am I doing wrong? I am trying to transfer my iTunes library back to my computer since I lost them all when an external HD crashed. Can somebody help me? Thanks.

I also noticed that there appears to be more songs and movies on the external HD when connected to my ATV than when connected to my computer. I did a reverse setup switching back to internal storage on ATV. Most of the files were missing. When I switched back again to external for storage, most of the files are there. But then when I connect the HD to my computer only a portion of the files show. What’s going on? I am using an Iomega eGo Portable hard drive, Mac Edition 500GB. It has FireWire 800/FireWire 400/USB 2.0. I have been connecting to both ATV and computer via the USB. Would that make a difference? I just want to save my iTunes library!!


All files present on the AppleTV will be transferred to the external drive. You can view/transfer all the files on internal drive by following the guide here:

I tried several times and not all of the files transfer. I still see the files on the ATV under Media.old so it appears that I haven’t lost them. So I am now transferring my files thru FTP (Cyberduck) from my ATV to my computer. However, it is extremely slow! Sometimes the speed is 56 KB/sec estimating that it will take 600 hours! Currently the speed is at 736 KB/sec with only 22 hours. Is there any way to speed it up? And it keeps asking me to “Allow” access. I have clicked on always but I still get the message so this slows it up even more. Can anyone help?

Thanks, but I did see this article and did everything it said. I have now been transferring the files since 7:30 p.m. yesterday and I am no even half way there. Estimated 38 GB to go, 16 hours remaining. It’s so slow. Plus I keep get a message to allow access. This halts the transfer until I click on allow. What can I do to speed things up?