Not adding movie to library

I don’t get it… I added a few movies today and everything but one movie is not found/added.

Any idea why? I’ve tried renaming it, moving it. But it still evades detection. I’ve checked permissions with other files and directories, they’re the same.

When I go to the directory through Files it is found and correctly recognised, yet searching for changes will not add this movie to the library, yet others will be added.


drwxr-xr-x@ 5 me staff 170 8 jun 23:11 Trailer War (2012)

drwxr-xr-x@ 5 me staff 170 8 jun 23:11 .
drwxr-xr-x 592 me staff 20128 8 jun 23:00 …
-rw-r–r–@ 1 me staff 6148 8 jun 19:23 .DS_Store
-rw-r–r-- 1 me staff 1096270376 3 jun 11:22 Trailer War (2012).mp4
-rw-r–r-- 1 me staff 74418 3 jun 11:11 Trailer War (2012).srt

Can you provide the file name so we can try and figure out why it’s not being matched?

1 Like

Just noticed it’s an mp4 file

So if it turns out not a naming issue I’m wondering if it has some rogue embedded metadata (assuming the op has it turned on?)

Also you may want to go to the Library settings page and make sure the movie is in one of the shares you have checked for the Library.

Did you check out the original post? It says it all in there, but to repeat:
Trailer War (2012).mp4.

There are 588 movies in that directory, and only one is not being added. I think I don’t need to check out how to set up the library…

@Hitsville (named after the Motown studio?) I just checked to be sure and the mp4 doesn’t have any metadata included.

But we saw this:

To be clear, just “Trailer War (2012)” works fine:

If you’ve got some weird folder delineation that isn’t indicated in the text you posted, try doing it again while surrounding it by preformatted text tags.

For best results there shouldn’t be anything in a filename preceding the name of the movie and the year the movie is released. Any other information you want to include (resolution, encoding stats, where and when you sourced the file, etc.) should only be appended after the release year.

“-rw-r–r-- 1 me staff 1096270376 3 jun 11:22 Trailer War (2012).mp4”
This is a directory listing. Start up a terminal and type and execute the comment ls-sl

This says that read and write permissions are granted to me, and read to everyone in the group staff and everyone else. The file xxxxxx bytes large and created on xxxxx. And the file name is…
I have a feeling that the problem doesn’t lie with me or Infuse, but once again with TMDB…

But why? Did your file not get identified? Your last picture seems to look like it did.

The last picture is from TMDB. My movie remains in the missing files

As there are 2 Trailer War entries at TMDB I guess Infuse gets confused and ignores it… Why it isn’t put in the Others section…dunno

Did you try doing an edit metadata and selecting the correct movie?

1 Like

But the one with the year is the only one that shows up with that filename / year, as I posted above.

The second entry looked like a duplicate that needed to be deleted. So it’s been deleted.

Unfortunately it doesn’t even show up in Others. Otherwise I would have tried

Yep, I asked support sir the divine entry, and it’s been deleted.

Now only waiting until it trickles down to all servers, as Infuse Mac still doesn’t see it (either in Movies or Other), I haven’t tried on the iPad or TV yet

Well I just tested this
Screenshot 2023-06-09 at 10.25.38 AM

And it produced this in Infuse automatically with no edit necessary.

1 Like

It still won’t load here (or anywhere) in Infuse. Is there a way I can look into the logs? See if I can find out what happens with this file?

Can you try browsing the share via the Add Files menu to see if the file is listed there? This menu will list all files (in a bare bones file list) regardless of whether they are supported in Infuse or not.

1 Like

Hey James,

when I’m in Infuse Files I can see the file just fine. the only weird thing is that it shows within the directory. The Matrix is a collection…

When I “Scan for Changes” it simply moves past it… Or so it seems. Hence my question whether I can view the logs. I am interested in knowing if it bothers to do something with the file, lol.

Can you show the actual filenames for the contents of that folder?

Long-pressing on that folder might show you the options to either “Use Local Metadata” or “Use Online Metadata”. Toggling that setting will alternately remove online metadata previously acquired, and seek it out again, respectively. It’s an easy way to get the contents of a single folder re-indexed.

Far as I know, logs generally aren’t accessible to users, but can be generated and sent to Firecore for analysis (via the “Submit Diagnostics” option at the bottom of the Settings page) if it turns out none of the suggestions above help you solve the issue and/or Firecore requests the information.

I’ve copied the file to another directory that I use , so I don’t have to show over 500 files and directories. In the screenshots you see what Infuse shows me from the root of that directory, inside the Trailer War directory and what FInder shows as apparently Terminal output isn’t clear. Obviously I cannot show what the Library does as it isn’t in there…

but for the ones who do… This is what ls -R outputs

Brian Wilson Long Promised Road (2021)
Charlie’s Angels (2019)
Mom And Dad Save The World (1992) New
Paul McCartney The Space Within Us (2006)
Son Of Sam The Hunt For A Killer (2017)
Trailer War (2012)

./Brian Wilson Long Promised Road (2021):
Brian Wilson Long Promised Road (2021).mp4

./Charlie’s Angels (2019):
Charlie’s Angels (2019).mp4

./Mom And Dad Save The World (1992) New:
Mom And Dad Save The World (1992) New.mp4

./Paul McCartney The Space Within Us (2006):
Paul McCartney The Space Within Us (2006).mp4
Paul McCartney The Space Within Us (2006).srt

./Son Of Sam The Hunt For A Killer (2017):
Son Of Sam The Hunt For A Killer (2017).mp4

./Trailer War (2012):
Trailer War (2012).mp4 Trailer War (2012).srt

I’ve already tried Local Metadata on/off, no Trailer War.

Edited metadata within the file (with mp3Tag) and when I change the internal metadata to Fast X (2023) I see Infuse grabbing it. Edit it to “Trailer War (2012)” , and nothing. Now it’s been emptied back to the orignal state.

Added an empty file named “Trailer War (2012).mp4” in the testfolder and that is immediately shown and parsed correctly…

Went back to beta version 7.5.1 (7.5.4394) to see if it was something introduced in later betas (nope it isn’t).

Installed yesterday’s beta, nope still omitted.

Added this directory to the Library and scanned: everything added but Trailer War.

Checked permissions on “good files” and Trailer War, made sure that they were the exact same. Nothing.



1 Like