Not able to read files from MacOS Catalina

Can you try installing the GM seed of Catalina to see if this allows you to connect without having to allow full disk access for smbd?

In our brief tests so far, SMB appears to work normally in this build of Catalina.

I have the GM already installed, and justed checked how it behaves when I a) uncheck smbd and b) completely remove it from the full access panel. In both cases I cannot access external drives etc. via Infuse. Then I gave it full disk access again, and it works again.

Strange that only some users see this behaviour! Are you sure you tried external drives or subfolders of the ~/Downloads folder?

Is the SMB version in Infuse set to Auto, or is it set to something else?

Has your external drive been added to the list of Shared Folders in System Preferences > File Sharing?

It’s Auto, and yes, the external drive is shared and the user which I use to access my Mac from Infuse has not only Read, but even Write permission for the shared drives and folders.

This is clearly an issue with Catalina requiring explicit user authorisation to access external drives, and given that smbd is a daemon without a user interface, it cannot ask for those permissions from the user and thus the request is just denied. Maybe if you install GM fresh directly from Mojave (without all the other betas in between) smbd is somehow given the required permission per default? Very strange. How about you try to add smdb on your machine to the full disk access panel and uncheck it, and see what happens then?

Oh, and maybe check before if smbd is given maybe File Access to removable folders (the topic below Full Access) already in your installation.

Interestingly enough, it looks like Catalina is in fact auto-adding smbd permissions upon a fresh upgrade/install, if File Sharing was previously enabled in Mojave.

Here are a pair of screenshots from a MacBook Pro which was updated from Mojave directly to the Catalina GM seed (19A582a) this morning.

Additionally, disabling File Sharing appears to also disable full disk access for smbd. Re-enabling then re-enables it.

This is encouraging, as it indicates Apple has resolved the issue so users upgrading from Mojave shouldn’t need to take any manual steps in order to continue using SMB with Infuse or other apps.

Very interesting! I guess the riddle is solved then.

1 Like

Dealing with this issue now as well. Can’t seem to get permissions. I can access shares that are on my main drive, but I cannot access any of the shares that are on external drives.

So are you using the public beta as the original poster was or are you using the released version? Have you tried the suggestions in post #31 of this thread here Not able to read files from MacOS Catalina - #31 by james

Apologies. I had tried that originally before I read this thread and it didn’t work. But tried again and full disk access for smbd finally showed up and now things are working again.

Thanks

Hi, it works when I followed this comment. Btw, for external drive, this problem would only happen in ExFat format drive, NTFS is woking as normal.

1 Like

Just updated to the released version of Catalina on my iMac. Now ATV4 Infuse cannot access any of my shares. I have verified that the iMac external volumes are being shared.

You’ll have to grant smbd the proper access rights. See the posts above on how to do it.

Thanks. Post 36 worked for me.

where can I find smbd
I looked everywhere

Look at post #36 for the instructions on how to find smbd.

many thanks it worked

Post 36 worked for me too :slight_smile:
Plex worked, so strange only Infuse is having this issue

Plex Server doesn’t use SMB to access to drives. You’d run into the same problem trying to access them with a windows computer or another player such as Kodi.

I know they use separate method to access drivers
My point is that this solution is something a homebrew app is using and not a solution for an app people including me have paid for. Annoying to have to turn in to hacker man just because the computer have been updated ?. This issue should have been properly addressed during the beta testing by the developers