Not able to read files from MacOS Catalina

I have recently upgraded the MacOS to Catalina (public beta), since then Infuse Pro cannot access the linked folder in my computer, it shows “Access denied”.
Any ideas?

Have you set up SMB sharing in Networks? Have you set the folders to shared or the drive itself?

New OS sometimes means having to redo permissions for net access.

I have set the folders to share. I have checked that the SMB sharing status remains the same after the MacOS upgrade.

I actually experience this on Mojave. Only the default ~/Public directory appears, despite adding new directories.

Thanks for the reports.

This seems to be something new in the b3 update. It’s not yet clear whether this is an Apple bug, or something requiring a change in Infuse.

This will happen if you attempt to connect as a guest (empty username and password) from Infuse to macOS.

I have the same problem with Catalina and Infuse on Apple TV. Maybe it has something in common with disabled NetBIOS in macOS 10.15.

There is release notes in Catalina beta 4 - https://developer.apple.com/documentation/macos_release_notes/macos_catalina_10_15_beta_4_release_notes

"NetBIOS is disabled in macOS 10.15 to speed up mounting, browsing, and connecting to SMB shares. Some older printers and file servers may require NetBIOS to connect. (51119111)

To enable NetBIOS, you can create or edit the /etc/nsmb.conf file. If your system doesn’t already have an /etc/nsmb.conf file, use the following Terminal commands while logged in as an Administrator:

echo “[default]” | sudo tee -a /etc/nsmb.conf
echo “port445=both” | sudo tee -a /etc/nsmb.conf

To disable NetBIOS, you can safely delete the /etc/nsmb.conf file."

I tried, but it didn’t help.

I renamed my computer and recreated the shares and all is working just fine… Maybe you can try this? I also created a sharing only user on my Mac. I did all the things toward the same time so not sure which did the trick I’m afraid.

John.

We’ve been working to track down what’s going on here, but in our tests this issue is no longer present in macOS 10.15b5.

Can you try updating, and let us know if the issue persists in the current beta.

I have the same problem. I can access shares that are on my main drive, but I cannot access any of the shares that are on external drives. I am using Beta 5.

I installed Catalina Beta 6 and Infuse is working like before!

Excellent!

Updated my iMac to Catalina 10.15 Beta (19A558d) and Apple TV to Beta TvOS 13.0 (17J5579a). Infuse is unable to connect to my shares. Getting the Access Denied error. Crap!!!

There are a few things to check.

  1. SMB is enabled on your Mac (more info here https://support.apple.com/en-us/HT204445).
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above).
  3. Selected username and password are being entered in Infuse.

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: https://support.apple.com/guide/mac-help/set-up-other-users-mtusr001/mac

Thanks James. Some good ideas but they didn’t work. I should have mentioned that I was on inFuse as an admin user of my iMac . I suspected that using the “user share” option you mentioned would be not be successful. I did have File Share enabled for all the users I tested (all admin) but to no avail. SMB seems okay! I lost the inFuse share on my other AppleTV as well so, to me, this means that Catalina is the problem. One thing of interest is that I keep losing the Shared Folder choice when I view the Info for my shared volume. Another shared folder keeps that choice but not my main volume. I will keep fighting this but sense I may be going back to Mojave. I would certainly entertain any other ideas. Thanks again!

Just to confirm, do you have these options enabled?

Yes!
/Users/grs/Desktop/Screen Shot 2019-09-16 at 1.29.41 PM.jpg

I am on Catalina Beta 15 now, still same problem. I have no trouble connecting to the share on my internal ssd, but cannot access any shares on external drives connected to my iMac Pro. Given that I am using a beta obviously I cannot complain, but I hope this will be fixed once Catalina becomes official!

Just brainstorming a bit, have you done a “Get Info” on both the folders and drives to make sure their set to “Shared Folder” and the “Sharing & Permissions” are correct?

Yes, that is all set correctly, I just checked again. It worked before Catalina!

Just to add to this, this is definitely a Catalina problem, not an Infuse problem. I’ve tried connecting to the smb share now from my MacBook Pro via Finder, and I can access the internal drives, but no external drives (for which I get an access rights error). So something is wrong with Catalina.