No "Standard" ATV Apps or Icons

Just bought & installed ATV FlashBlack.

Everything’s cool… but none of the “standard” ATV apps or icons are appearing.

No YouTube, Netflix, WSJ, etc…


That normally means that you either do not have a working internet connection, or you have not yet entered your itunes id.

Internet is live and Apple ID entered (for Home Sharing).

I’m located in Singapore… could it be related to that??

Long time user, Same issue after flash with Season Pass and aTV Flash Black.

Absolutely no icons on home screen except the Home and settings, with a third at the bottom (aTV Flash settings).


So go into the settings setup my apple account (log in) - nothing.

So go into aTV Flash settings and try to install PediaPlayer - sorry (error).

Same for all the rest.


Internet is fine (writing this aint I), so that’s not it.

Please assist, my Apple TV is a piece of shit without Netflix and the MediaPlayer!


Are you located outside of North America??

I have a feeling the ATV somehow sees where you IP address is coming from and turns the standard N. America content off??

Anyone else have any ideas??


I’m experiencing the same problem. Only have Computer, Settings, Maintenance and MLB.TV icons. I realy need all the other ones.

I’m definetly connected to the internet because I can use couch surfer and Weater is also installed and works fine. Same about media player, connected to my HDD through my airport extreme and works fine. My apple ID is set to USA, Boston and also my apple TV although I live in Iceland.

I used the newest Seasonpass and aTV flash 1.5. I also tried to do a clean restore on my apple TV through iTunes and all I got was 3 icons, Computers, Settings and MLB.TV


So can anyone help me. Do I need to SHH and change something there?

This suggests that the issue is nothing to do with the jailbreak as the clean restore resets everything back to factory settings. If you can work out how to get the icons back on a clean system then the same process should work on a jailbroken system.

I have the feeling that the software looks at your IP address and then determines which icons/features to enable.

Have a brand new, ATV3 still in the box at home.

Will try it out (from Singapore)… unjailbroken… and let you know what icons appear


Found a solution…

  1. Start AppleTV -> Settings -> iTunes Store -> Location (SET TO US)

  2. Sign in (login with your AppleID account)

  3. All the icons are in place!!! =)

If that one simple task didn’t worked, then you prob. have to change your Address in your AppleID account to somewhere in US

Well done, gardarhe !!!

It works!

But tried both with and without logging-in to the iTunes store… you actually don’t need to log-in.