No space left on device error (again)

I really thought I had this figured out. I tried to do an “Update All” from Nito TV, and it tells me “No space left on device”. Last time I had this problem (there’s a post here about it), I was able to SSH into the Apple TV and do a “apt-get clean” which freed up space. However, I’ve done that, and no luck. 

And since there’s no space left, I can’t even uninstall some things (I have Plex, XBMC, and a few others installed).

Help anyone? What is sfe to delete, via command line, to free up space?

 

Well, I’ve made some progress. I deleted the syslog, which enabled enough free space to allow me to uninstall some things, like various XBMC skins and video add-ons I didn’t need, and to uninstall Nito options like the VNC server I didn’t need. So now I am up to 390M free.

What is a “usual” amount of free space? Do I still have something huge taking up space that I haven’t found yet?

Is running out of space normal?

 

The device is only 8GB so it is quite easy to run out of space if you download anything to it. Have you downloaded any movies from iTunes or XBMC? They should be somewhere in /var/mobile if you have.

I tried to update and got ‘out of space’ errors but everything was fine after I’d deleted a couple of downloaded films. I use WinSCP to log into my ATV2 and it’s just like using a twin pane file manager. You can back up films from your ATV2 to a local drive using drag and drop (or vice versa - I sometimes get better results copying a film to the Apple TV2 rather than streaming it from a share).

I don’t think there’s a direct equivalent for WinSCP on the Mac but I’ve heard Cyberduck is pretty good.

 

Never bought anything on iTunes. :slight_smile: May have tried watching a movie in XBMC. Do you know where in /var/mobile that downloaded video would be?

 

I use FileZilla, which will do SFTP as well as other types of file transfers.

Mostly what I want to do is use Plex, accessing my Plex Media Server for Win, and XBMC, for streaming video sites. Plex streaming doesn’t seem to work with PMS for Win, so I watch TWIT and Revision 3 and other online video networks from XBMC.

 

 

Don’t own a Mac; never have. Just Win and Liux desktops, and the Apple TV. Oh, and now an iPad.

 

Check the video cache folders:  

/private/var/mobile/Library/Caches/AppleTV/Video/LocalAndRental

/private/var/mobile/Library/Caches/AppleTV/Video/Other

 

anytime I have had the diskspace issue it was because of the CachedMediaxxx files in those folders. It should be safe to just delete everything in the folder including the .plist file

 

THAT’S what I’m looking for. I deleted everything in the “LocalAndRental”, and freed up 5.6G of space.

 

THANKS!!

This fixed my problem as well.  Thank you.  Does anyone know what causes this to occur?

 

From what I have seen in the forum It seems to be common if you have Plex installed for some reason.

for newbs, how do I do this? directly on ATV or Cyberduck? Ive been downloading lots in Icefilms and Navi-X and thought i was deleting them after watching.  Apologies - I’m learning…

I have never had Plex installed and just deleted 5+ gigs in there. File timestamps were 6 months old.

How do I delete items? how much hacking can be done until something bad happens!

You can delete files using the “rm” command.

From the Video folder, enter the following commands.

rm -r Other/*
rm -r LocalAndRental/*

This will delete the offending files (and folders if there are any) within the LocalAndRental and Other folders.

Don’t play around too much in the terminal environment until you are more familiar with linux terminal commands. You could do some serious damage to your file system!

How to solve this apt-get -f install?

No matter what I want to install either Couch Surfer or Last.fm all I get apt-get -f install.

Please help if anyone has any solution.

thanx dude, that solved my problems, too!

Totally new to this and do not have a clue where to go to free up space. Where are these files located that I can delete to free up space i.e. nito or xbmc? Please help! This is driving me crazy!!

The easiest way to view these files is to use Cyberduck and connect via SFTP. More details on this process can be found here.

Is there any way to clear cache on my ATV2 using USB (i.e. without need to connect to a wifi network?)

This is issue keeps arising every time I use the appletv to watch purchased itunes content I am using the latest software, is there a fix to prevent it from doing this?

Update: oh I found a clear caches option in the maintenance settings menu…sighs…lol