No sound with Infuse Pro on Apple TV 4k and HomePod

I’m using Infuse Pro on Apple TV 4k and HomePod.
I love it and it works fine until today.

It plays the movie but no sound from HomePod.
I tested Netflix and Youtube. No problems.
I tested Infuse Pro again. No sound.

I tried to restart Apple TV.
I tried to uninstall Infuse Pro and install it again.
No help.

Welcome to the forum!

Improved support for AirPlay 2 and HomePod is currently in progress for the upcoming 5.8.2 update.

1 Like

If this helps at all. I’ve been having intermittent sound issues, everything works fine on all other apps and sadly Infuse drops sound to my HomePods now and then. Looking forward to the 5.8.2 update that will help.

So my set up is this.

Apple TV | Audio format set to Stereo. (Settings > Video and Audio > Audio Format > Change Format On/ New Format Stereo
Infuse | Audio Output set to Auto.

Apple TV is on public beta! This might also be a factor is why my sound comes back after a restart and yours doesn’t. Might.

The only thing that gets sound playing to the HomePods for me, is restarting my Apple TV. I know you’ve tried this but it might be worth changing the audio settings of the Apple TV to see if it kicks the HomePods into action.

So, change the audio setting. Test, if still no joy, restart and test again. Hope this helps.