No Sound on MKV files, MKV Crashes, subtitle crash

Hi

I got a ATV2 With ATV Flash Black.

When i run XBMC, and try to Run MKV files 720p, it crashes. sometimes i can run it, but there is no sound. it also happens with other files. Xvid og Avi.

and if i try to run subtitles on, i doesnt work or the movie crashes

please help. this ATV2 drives me crazy

 

Hi,

 

I have had the same problem.

First time when I updated to 4.3.1 and installed the official xbmc, after some reading on different forums I installed the lates nihtly build of xbmc and problem disappeared.

Today I had the problem again after I installed  the media player, after re-insatlling it worked ok again.

Hopefully when SMB is supported by media player so I can use it 100%.

 

 

Well, what i found, seems the VideoToolBox is crashing the whole stuff, if you go to system, then Video, Playback and Untick "allow hardware accesleration (VideoToolBox) everything runs fine with XBMC...well downside being videos are getting sluggish -_-;

 

Seems to be a bug with the API, and I hope the dev will try and do something about it :-)

Ler me know if this work, did bang my head on brickwalls for this one before my xbmc stop crashing on certain files...

Cheers,

Benj.

 

I have this problem as well.  Have to turn off acceleration or get crashes.  Result is mkvs play but are not watchable. Is there some kind of fix for this? Why Do I have to turn it off and it works fine for others?