No sound during LG HDR UHD demo file "New York"

I tried to play the LG HDR UHD Demo File, which is available here:
Playing the Video is possible but there was no sound. I checked a couple of options but wasn’t able to hear the sound of that video.
A bug?
I tried the same with another product starting with “M” :wink: on my ATV and it worked perfect: HDR picture and sound.

Does someone has an idea why there is no sound with Infuse?

Is this affecting all files or just a few?

A few settings to check.

  1. Check ‘Audio Output’ in Infuse > Settings. We recommend Auto.
  2. Check ‘Audio Output’ and ‘Surround Sound’ in Apple TV > Settings > Video and Audio. Ensure Audio Output isn’t set to an AirPlay device, and Surround Sound is set to Best Quality Available.

Thanks James for you reply.
It is happening for just a few videos (e.g. that mentioned LG video) - all other videos are working fine.
I double checked your proposed settings again (also listed here: Audio Options (tvOS) – Firecore) and all settings are fine.

When swiping down during playback it shows: “sound-track: none”. Obvioulsly Infuse does not recognize a valid sound track within that file?

Hmm, we’ll take a look.


Yes James, I can confirm that too, The 4K videos from LG & Samsung produced beautiful colors in HDR but no sound on my Apple TV 4K, iPad Pro & iPhone X. It’s the same videos I posted in HDR not working right - #7 by oric1

I think the demo files from that they linked to YouTube originally does not have sound because when I played the demos on Safari, there’s no sound too so I doubt it’s Infuse problem.

The file does have sound. Use another player and you can hear the background music.

My bad. You were right, I played the same LG & Samsung demos below using VLC Player and is background music, only Infuse unable to play the music.

Both the files are in .ts format.