No software will install in aTV Flash Black

I got my 2nd gen AppleTV jailbroke with SeasonPass and installed aTV Flash Black, but when I try to install last.fm, couchsurfer or anything through NitoTV, I get error messages that it's missing dependencies - nothing will install.

Also, it seems to have killed my Netflix - just won't connect anymore.

Help?

I'd like to bump this thread, same issue here, except Netflix still works for me. Nothing will install with the missing dependencies message.

 

Any ideas?

This was an issue in the initial release (0.6.4.) of Seas0nPass.

Downloading the latest (0.6.7) version and re-jailbreaking will correct this issue.

James

 

I am using 0.6.9 of seasonpass and the latest version of ATV Black. I have even gone as far as purchasing a secondhand macbook to try and get this working....

 

first of all the jailbreak works ok, can reboot and continue the setup (I restored the standard ATV software so had to set up preferences). I then ran the flask which told me that the software had been installed successfully, however the ATV did not restart as mentioned in your install guide. The screen went blank for a second and then returned to the standard menu. A teathered reboot fixes this and the maintence menu is shown.

 

When selecting the manage extras menu this takes a while, ie 15 - 30 seconds to load. once in the menu selection is very slow at changing. I have tried to install each of the extras to no avail. even after a reboot they are not on the menu bar, any ideas?

I've downloaded the latest SeasonPass 0.6.9 and I'm afraid this happens to me as well. Looks like this issue might be back in the new release. When pressing Plex it looks like it starts installing com.plex.client-plugin, but after ........hehehe never mind. It works! Not sure why but hey...maybe someone else knows..?

As you Viper.But not so lucky at the end.After many many many many times still no XBMC or Plex. It start installing but after nothing happens.Tried also to reboot the AppleTv.Nothing.Don't know what to do!! Help

I put in a tech request and the response I got was poor internet connection.

I connected my unit via ethernet instead of wireless and all applications installed fine.

That said I now have a problem with XMBC trying to play VTS files, starts to load and then crashes back to the front menu.

I’m ethernet connected.Maybe we just got to have patience.This evening I’ll try again.
:slight_smile:

Same issue here - cannot get it to install - tried sooooo many times - using ethernet too..

Nothing :frowning:

Is there an error you are receiving when attempting to install something or what exactly is happening?

Hi.
Till this morning nothing happen.
But today I get “pkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.”
I follow this typing in terminal, then follow the standard installation from terminal and all now is installed.

All ok tanks

Which version of AppleTV software are you running? (Settings --> General --> About)

The last one.Just controlled upgrade before JB last Sunday morning.
Is enough or do you need the number version?

Hi

I also got the dpkg error message while trying to initially install XBMC from the ATV menu.  It was "thinking" (circular 'wait' icon spinning) for a minute then came back with that error message (the same one you posted above).  After that, nothing else would installed.  I was on wireless (since that's all I can get where the ATV is) and that might have been the problem.  So, I first SSH'd into the ATV, then ran 'dpkg -- configure -a', then used the Lifehacker terminal XBMC install guide to get XBMC onto the ATV.  After a reboot, XBMC showed up on the ATV menu.  I'm not sure if the other packages (nito, plex) will now install after running the "configure" command...I didn't have time to try it.

I had the same problem took 3 times to restore in Itunes then use seasonpass but it finally worked and everything installed no problem.