No NBA on the Internet menu

Im missing the NBA option under the internet menu, anyone experiencing this? any solution? Thanks

same here since atv flash upgrade

So it isn’t just me!  I just spend a good 45 minutes tinkering around trying to figure out why the NBA is missing.

Can anyone comment on a solution to this???  Very annoying that is happens right as the season starts.  

I have two Apple TVs, one on 4.2 and one on 4.3.  Both are on untethered jailbreaks done with Sn0wbreeze.

I submitted a support ticket, so we’ll see what they say.

What version of Apple software did you install during the Jailbreak process? If you went for the 4.4.4 software and a tethered boot then you should have NBA. If you won’t for the 4.3 software and an untethered boot then I do not believe NBA is available.

Do you all have iTunes Store set to something other than USA?

Go to Settings>General>iTunes Store>Location>USA.

I had to change mine from Canada to USA, works perfectly fine now.

I have 4.3 and USA itunes store and no nba for me.

Same problem here. I had to restore to factory default in order to have access to League Pass again.

My iTunes location settings are correct. I believe I was previously on 4.3 software before the new update of atv flash software and had nba option working The nba option was made available beginning with apple tv software version 4.2. Why would Apple take it away on 4.3 and bring it back on 4.4? I don’t believe they did. here’s the change log for Apple tv software http://support.apple.com/kb/HT4448
I believe this is a atv flash software bug. We definately need some input here from someone associated with Firecore.

 

Maybe because it was “NBA League Pass” before 4.3 and now “NBA TV” with 4.4? Just an idea.

Before I installed ATV Flash I updated my new Apple TV to 4.4.X and set the iTunes settings to location: USA. Worked fine. Then I did an untethered Jailbreak to 4.3 and no NBA anymore. NHL is missing to (which is ok since it was released with 4.4).

Having the same problem. This is ridiculous that no one from the team has responded to this issue.

I’m in the same boat… signed up for the League Pass free preview and I can’t use it, grrrrrr…

But other than that I’m happy with aTV Black… I’m sure we’ll get an answer soon. These guys are enjoying time with their families during the holidays.

Make sure you are jailbreaking and tether booting using the same computer. Using different computers will cause weird anomalies.

Anyone with 4.3 untethered here who has NBA in the menu?

 

I sure as hell don’t have it.

Not here either

I’m missing it as well. I had 4.3 untethered and I’m now on 4.4.4 untethered and still no NBA (or MLB/NHL). Can this be addressed?

 

Not even MLB? That’s weird.

Also missing this - iTunes correctly set to US

I jailbroke it again after the 4.4.4 update, installed aTVFlash 1.1.1. and the NBA menu is back (US Store)